Rhino 6 - Copy and Paste Error (Edits Environment Name)

@harmcoster, when you see this again, could you check your desktop for a file called RhinoDotNetCrash.txt? If you can find one, please attach it here.

I cleaned op the tempory file folder like you suggested, but it still gives the error.

I searched for a RhinoDotNetCrash.txt file, And foud one, but this one was from at least a year ago.

Ok, probably not what we’re looking for then :slight_smile:

I just don’t understand it. 2 hours ago I opened a new rhino file and it didn’t work. Now a few hours later it is working wihout rebooting the laptop or closing that specific rhino file.

Just a quick update. I don’t know how it is possible, but after my last post i didn’t get the error message again. So for now i’am a happy man. Thanks all for the support.

Thanks for letting us know. The general feeling here is that it was something to do with your computer, like some problem in Windows or something strange happening in the file system. Just out of interest, do you have a 3rd party antivirus system installed? Sometimes they can ‘attack’ files that are being written to if they look ‘suspicious’. Just an idea. Anyway, it looks like it sorted itself out. I hope it stays working for you.


it’s interesting your mentioning that, because i indeed had a antivirus system installed which i didn’t use, so when this problem occured i tried to clean my laptop, and i also deleted this software (don’t know the name any more, but if i come up with the name I will let you know). After that it did work, but it never crossed my mind this could be the problem. But i think its safe to say this could very well be the issue…


Aha! Thanks for the information. This is good to know in case it happens to someone else. In my experience, some antivirus ‘solutions’ cause more trouble than they’re worth.


In my case was a problem with windows that not let me write in temp directory. I solved opening Rhino as administrator