Rhino 6 bug - I cannot install license


#1

I have purchased Rhino 6 upgrade. I have downloaded it and I have attempted to install it. At the end of the installation, I entered the Rhino 6 Licence Key. Rhino asked me to use online account. I do not use Google, and I will soon quit Facebook, so I created new account with new password. The following screenshots illustrate these actions.


About 10 minutes later I received email from McNeel, and I clicked on the link in the email. When I tried to login to my account (next screenshot), nothing happened.
login to your rhino account 2

When I launched Rhino 6, the following message appeared:

I tried to launch Rhino 6 again. I failed and I was caught in a long loop made of these messages:

rhino 6 contacting servers
rhino 6 no licences


rhino 6 requires license


(Wim Dekeyser) #2

From this, it is not clear (to me) if you actually add your license to the Rhino account or not…


#3

What do you mean?
I clicked on the link in the email again, and I got second email. When I clicked on the link in the second email, it sent me to my new online account. This time the account worked. I had to perform several undocumented tasks in my new account. It seems that Rhino 6 works now.

Why is it more difficult to install legitimate version of Rhino than bootleg copy from Pirate Bay?
Are you going to make video tutorial about this Byzantine installation procedure?