Rhino 6.1 not working properly overnight

unhandled

(Ganzoganzoganzo) #1

Problem seemed to have been solved when installed the graphics card update.
I shut down my computer and when trying to open Rhino 6 again, same problem.

This is the system setting part that was changed after the update. Everything else is the same as before.

Rhino 6 SR2 2018-3-6 (Rhino 6, 6.2.18065.11031, Git hash:master @ cd4fa1dcdec31cb58baacef0855771173af7196f)

Windows 10.0 SR0.0 or greater (Physical RAM: 5.8Gb)

Intel® HD Graphics 4000 (OpenGL ver:4.0.0 - Build 10.18.10.4885)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 2x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.0
Shading Language: 4.00 - Build 10.18.10.4885
Driver Date: 12-11-2017
Driver Version: 10.18.10.4885
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2176 MB

Original Post:


Hello, I have been using Rhino 6 for a couple of weeks now. It had been working well and I had found no obvious bugs.
I opened it today and had a really long loading time, after no updates or any other changes to computer overnight.
When it opens, just to rotate the view in the perspective viewport takes about ten seconds, the same for making even a point.
Safe mode runs well but I need the surfaces and meshes displayed.
I then updated to Rhino 6.2 but no changes were apparent.
I tried reinstalling Rhino 6.1 and 6.2 and the problem remained.

I had a similar problem with Rhino 5, and solved it when I disabled OpenGL

Is there a way to disable it in Rhino 6? I don’t find any obvious cause this may have happened.

These are my current settings:

Rhino 6 SR2 2018-3-6 (Rhino 6, 6.2.18065.11031, Git hash:master @ cd4fa1dcdec31cb58baacef0855771173af7196f)

Windows 10.0 SR0.0 or greater (Physical RAM: 5.8Gb)

Intel® HD Graphics 4000 (OpenGL ver:4.0.0 - Build 10.18.10.4358)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.0
Shading Language: 4.00 - Build 10.18.10.4358
Driver Date: 12-21-2015
Driver Version: 10.18.10.4358
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2176 MB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”


(Pascal Golay) #2

Hello - I would test again after a driver update. It might or might not help, but I’d get that out of the way if there is a newer driver available from the Intel website.

-Pascal


(Ganzoganzoganzo) #3

Thank you Pascal, I updated my driver and it works normally now. Seems so obvious to me now.
Still I wonder what could have caused the issue so suddenly.
Thanks!


(Ganzoganzoganzo) #4

Problem seemed to solve but happened again after resart. Could there be any other issue?