Rhino 6 update slowed it waaay down


#1

Hi,
I have installed rhino 6 on my old microsoft surface pro and it worked great for simple stuff, plans and whatnot.

I updated rhino6 yesterday and now it is plain unusable. Everything is sloooooooow, I mean everything, like opening the “file” dropdown takes a long time like it is waiting on a timeout.
Does this sound familiar to anybody ?

gr
s


(Rodrigo Bárcena) #2

Sander,
Can you run the _SystemInfo command and paste the result here?
Also, did you recently install any windows update? Do you know which exact version of windows you are at?

Thanks!


#3

What is most noticeable is that the windows themselves redraw very slowly, 3d frames included, but I am inclined there is a microsoft borne issue here.

Windows 10 Version 1709
I am aspplying the latest update as we speak (KB4103714), aside from that I am up to date.

output of _SystemInfo
############### start
Rhino 6 SR4 2018-5-10 (Rhino 6, 6.4.18130.19341, Git hash:master @ 51190de75f80526c68ef8bdf62938fe1eb6ccc8a)
Licence type: Commercial, build 2018-05-10
License details: Cloud Zoo. In use by: Sander Boer ()

Windows 10.0 SR0.0 or greater (Physical RAM: 3.9Gb)
Machine name: SUN-RA

Intel® HD Graphics 4000 (OpenGL ver:4.0.0 - Build 10.18.10.4252)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.0
Shading Language: 4.00 - Build 10.18.10.4252
Driver Date: 7-10-2015
Driver Version: 10.18.10.4252
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2103148 KB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
############### end


(John Brock) #4

Try turning off the hardware acceleration:
In Options > Advanced, use a list filter of “hardware” and set it to False.
That should be better.


(Steve Baer) #7

Hi Sander,
I wouldn’t turn hardware acceleration off just yet. Was your surface running a previous version of Rhino 6 smoothly? If so, we can try to get you back to the older build to see if that version works.

I would also take a look at the Intel HD driver to make absolutely sure you have the latest version. Your driver date is 2015 which is pretty old, but that may be the last time Intel updated for this card (I’m not exactly sure).


#9

Hi Steve,

Thanks for replying, after the win update the windows are responsive again, but 3d is garbage still.
Last week I drew up some room divisions and now I can’t even move the grid around. fps is .125, it takes app. 8 seconds for the view to refresh.
Downloading intel driver now, will report back in a sec.

gr
s


#10

#define RANT

Intel driver refuses to install, refers me back to the vendor, i.e. microsoft.

And omFg what a shirtshow is the microsoft webpage, they’re calling the latest surface also the surface pro, not surface pro4/5/6/7/etc, I can’t find drivers to save my life. There is a “Surface” app in the store, that just links to the ms website. Registered my device with microsoft, only to be met with the message that my device is out of warranty and a link to the nearest microsoft store, no drivers, forums, nothing.

Regardless, I tried the updates for the “Surface Pro”, only to be met with the insult of “this is not a surface laptop”.

So I went into the device manager, uninstalled the intel HD400, restarted, driver got reinstalled magically and presto, Rhino 6 works like a dream again. What the fricking heck ?

#ifdef RANT
Remember me asking about a linux port ?
I know, I know, you’re not considering it, but please consider it as a long term goal.
I will gladly trade Microsoft’s opaque mediocrity and general ineptitude for the jungle that is linux. I much rather hack a path for myself than be sent down wrong paths in a maze.

“yeah, but corporate clients [etc]” ,
have you seen a current corporate setup of late ? They’re vmware clients ffs, for mail and office work. I sat in meetings with adesk reps that seriously suggested running revit on a virtual machine.
My point is corporate IT has lost the plot and I can only see this situation imploding hard and I can easily see microsoft going the way of Novell.
If I was a dev, I would seriously consider being as platform agnostic as is humanly possible.
#endif


#11

I managed to install a more current intel driver and now everything is working smoothly again.
Getting that driver installed took some voodoo though, I’m not sure I can replicate the steps…

anyway, thanks for the effort of replying,

Sander


(Steve Baer) #12

Just curious; what does SystemInfo report now?


#13

Hi sanderboer,

I have the same configuration as you and have the same problems here with the HD4000 for about 9 months. (WIP (5.9.2017) :s-----l-----o-----w-----e------s-------t display ever ;)). Sometimes it works like a charm, sometimes the viewport refresh rate is nearly dead. I have played with all windows 10 and Rhino settings, different extern monitors and drivers, but haven’t found a solution. I suppose 4GB RAM is just too low for this configuration. My system.txt (1.7 KB)

Cheers

Michael
www.flexiCAD.com


#14

######### start
Rhino 6 SR4 2018-5-10 (Rhino 6, 6.4.18130.19341, Git hash:master @ 51190de75f80526c68ef8bdf62938fe1eb6ccc8a)
Licence type: Commercial, build 2018-05-10
License details: Cloud Zoo. In use by: Sander Boer ()

Windows 10.0 SR0.0 or greater (Physical RAM: 3.9Gb)
Machine name: SUN-RA

Intel® HD Graphics 4000 (OpenGL ver:4.0.0 - Build 10.18.10.4885)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: None
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.0
Shading Language: 4.00 - Build 10.18.10.4885
Driver Date: 12-11-2017
Driver Version: 10.18.10.4885
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2103148 KB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

######### end