Rhino 6.0 Crashes During Sleep W/ NVIDIA High Performance Mode

I am using Rhino 6 on windows 10 on an
XPS 17 9700
NVIDIA RTX 2060 Studio Driver
64 GB Ram
Intel 9th Gen Core I7

I have a well capable machine. However, anytime I run Rhino 6 on NVIDIA High Performance mode, and put it to sleep or leave it idle, the laptop either shuts down once it sleeps or remains powered on but not accessible, yet the fans still run.

I have done multiple tests to mistake sure it’s not a hardware problem. I did diagnostics .The Graphics Card is Fine.

I reset all the drivers. Still does the same thing.

All the other programs work with the same graphics card settings. I have tried this on all my Adobe Products and put it to sleep, the laptop works fine. It only does it with Rhino. Both in normal and safe mode.

I always get the power state failure. And it’s directly related to the crashing of Rhino + NVIDIA. Again, I honestly think this a Rhino issue and not an NVIDIA issue since my NVIDIA works with every other program on the exact same settings and does not crash on sleep. your help would be truly appreciated.

ADDITIONAL_XML: 1

OS_BUILD_LAYERS: 1

BUGCHECK_CODE: 9f

BUGCHECK_P1: 3

BUGCHECK_P2: ffffa88f6e1d7600

BUGCHECK_P3: fffffa8183eaf750

BUGCHECK_P4: ffffa88f8ba7a060

DRVPOWERSTATE_SUBCODE: 3

FAULTING_THREAD: ffffa88f698b0040

ADDITIONAL_DEBUG_TEXT: DXG Power IRP timeout.

IMAGE_NAME: nvlddmkm.sys

MODULE_NAME: nvlddmkm

FAULTING_MODULE: fffff8072f330000 nvlddmkm

I’ll bet the Rhinomeisters will definitely want a look at the complete systeminfo.

I was using a desktop a couple weeks ago with a 2080ti that had trouble with crashing Rhino on waking up. That’s bizarre, the kind of problem that used to be expected like 15 years ago. First, update to the latest ‘gaming’ driver, the ‘studio’ ones don’t get updated as long.

This happens on both the older and newest drivers.

systeminfo from rhino and a screen shot of your nvidia settings will be helpful.

I have tried both the default and the high performance. High performance it will crash. So I have to stick to “optimal power.” But If use high performance for any of my other adobe CC programs, it stays awake and functions normally. I have used both the new and last driver. Also, this has happened on all 3 brand new laptops.

Rhino 6 SR30 2020-10-14 (Rhino 6, 6.30.20288.16411, Git hash:master @ aa50c15036dbe0dbd38214d6ca94d76dbecda24d)

Windows 10.0 SR0.0 or greater (Physical RAM: 64Gb)

Hybrid graphics system.
Primary display: Intel® UHD Graphics (Intel) Memory: 1GB, Driver date: 5-19-2020 (M-D-Y).
Primary OpenGL: NVIDIA GeForce RTX 2060 with Max-Q Design (NVidia) Memory: 6GB, Driver date: 7-13-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 451.77

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-13-2020
Driver Version: 27.21.14.5177
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.30.20288.16411
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.30.20288.16411
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.30.20288.16411
C:\Programs\Enscape\Bin64\Enscape.Rhino6.Plugin.dll “Enscape.Rhino6.Plugin”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.30.20288.16411
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - I would at least try disabling Enscape in Options > Plug-ins page and then restarting Rhino - does that change anything?

-Pascal

I see from Nvidia’s driver download page:

that their current reference drivers for your card are 456.71 (studio) dated 10-20-20 and 457.09 (gaming) dated 10-29-20. Of course Nvidia recommends that laptop owners obtain their drivers from the laptop manufacturer.

Just to be sure you’re up to date to eliminate your older driver as the cause it might be a good idea to check for the latest driver.

I don’t know enough about laptop drivers to give any more advice, but I do know from experience that the Nvidia drivers work just fine on my Dell workstation.

I’ve always ignored that advice and used the latest NVidia drivers from their website. Never had a problem.

1 Like

But does this mean that enscape will not start or not be in use? I’ve had this problem before installing enscape.

This is a troubleshooting, problem identification step, not a proposed solution.