Rhino causing Windows to crash - PC can't wake from sleep when using Rhino

Hi folks, I am running Rhino Version 6 SR21 on Windows 10: a Microsoft Surface Studio 1 with an NVIDIA GeForce GTX 980M card and if I leave the computer and it goes to sleep with Rhino up then the machine locks up when I try to wake it up. The fan is running but the screen remains black and it remains unresponsive so I have to resort to a hard shutdown. Then the performance is incredibly slow during restart and logon until I restart yet again and then things run normally.

I have tested whether this same crash happens without Rhino running and it does not. I have also unistalled the Orca3d plugin and its associated license management software that I was using, thinking that could be the problem but that did not fix the problem. Rhino is setup out-of-the-box otherwise so there’s not much in the way of plugins or special settings to suspect are responsible.

I have also checked that Rhino, Windows 10 and the drivers for NVIDIA card are all up to date.

The only work around for now is to turn off sleep mode but I would prefer to fix the problem. Anyone familiar with this problem or have any suggestions??? - your help is much appreciated!

-Josh

I have no idea what can cause this but:

  • have you tried to run Rhino in safe mode?
  • is Rhino the only program that causes a lock up?
    Even though everything is up to date, you still might want to post your system info by running _Systeminfo in Rhino and post the result

Hi Gijs, and thanks for the suggestions.

I have run Rhino in safe mode with the same result: computer can not wake up and requires a hard shut down.

There is no other application or condition which causes this problem: only Rhino.

Below you will find the system info from Rhino. Please advise on what I might do to troubleshoot the problem. This is a newly setup machine without much else installed so this shouldn’t be too difficult to diagnose. As I mentioned I did have the Orca3d plugin evaluation installed and it has a license manager called CopyMinder which I first suspected to be causing the problem so I removed the plugin - I think completely though you never know for sure.

Thanks in advance for your help.

Think you forgot to paste in systeminfo

That’s odd. It’s in the email I sent, though separated from the body text by three dashes. Anyway here it is:

Rhino 6 SR21 2019-12-17 (Rhino 6, 6.21.19351.09141, Git hash:master @ 4d373f64ffb55e3a8d607d9618590728d86fb1e9)
License type: Commercial, build 2019-12-17
License details: Cloud Zoo. In use by: Joshua Teas ()

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: DESKTOP-1D04J5H

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 980M (NVidia) Memory: 4GB, Driver date: 12-24-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 441.87

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-24-2019
Driver Version: 26.21.14.4187
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.21.19351.9141
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

J P Teas

Hi Josh - do you have any ‘screen-saver’ type thing that comes up before the Sleep time? I don’t think those are around much any more but I know they would occasionally cause trouble for Rhino.

-Pascal

Yeah weird, I remember this sort of thing used to be a common issue back in…geez I dunno sometime before Windows 7? Maybe on a particularly crappy laptop from the 00’s? Odd.