Rhino 5 Is Freezing While Loading, It can't get past "Preparing Viewports..."

I’m running version 5 SR13 64 bit. I just bought a new Dell Inspiron 17 with NVIDIA GEForce940MX, and Rhino crashed a couple times while I was rendering. So, I updated the video card at the Dell website. Ever since the update, Rhino freezes during the “Preparing Viewports…” section of the booting operation. I don’t know if this may be a coincidence. I just see that green loading bar scrolling over and over again.

Please help me get back up and running. I’m not a seasoned pro at Rhino, so I’ll need to walk through this repair slowly.


Mike Gennaro

This is what I see on the screen…

Start Rhino in Safe Mode (Use the Windows 10 Search tool to find the application shortcut), to verify Rhino starts without OpenGL and plug-ins.
Assuming it does, then in Options > View > OpenGL, uncheck the option for using accelerated hardware modes.
While you’re in Options, go to the Plug-ins page and change the list filter to Plug-ins that do not ship with Rhino.
Disable all of them including RhinoCAM.

Close and Restart Rhino normally (not Safe Mode) and verify Rhino opens.
Go back into the OpenGL options page and ad the check back to using accelerated hardware modes.

Close and restart Rhino. Verify it opens properly.

Next, systematically go into Options > Plug-ins and enable one of the disabled plug-ins.
Close and Restart Rhino.
Assuming Rhino starts OK, keep enabling the plug-ins, ONE AT A TIME, and restart until you find the offending plug-in.

Then you’ll know what is causing the problem and can chase down a solution.

(got him on chat)
It looks like the drivers were never really installed, at least his machine does not recognize the card at all, not just Rhino.

I would always go directly to the NVidia driver download website for the video card drivers… Get the latest WHQL… --Mitch

I have a Dell with a different GeForce “M” card, and while the drivers from nVidia did run, they did not properly switch to the GeForce card when installed.
I had to use the Dell supplied drivers or Rhino was stuck on the embedded Intel.

I don’t know if his “MX” has the same issue or not.
GENERALLY speaking, your “Always” advice is good but there are a few exceptions.

I have similar issue i cant run rhino if 1080ti and k5000 is installed at once. Any cure for this disease?

Btw. Which one i should use for rhino viewport? So far i alwawys thought that quadro are better when it comes to viewport but is that true in case of comparision 1080ti with k5000 ? Someone ?

Oh and btw. is there any possibility to bound two viewports together i mean i have for eg. floating viewport on second screen where i want to have always interactive rendering turned on and on second screen i want to model and change stuff - in some cases when working on certian shot it i super handy bit sometimes i would like floating viewport to show exacly same viewport where i model and change camera same way basicly a clone - is that somehow doable ?

Found online :smiley: testmoocow fantastic command !!!

I agree. I use it all the time in Rhino 5.
Trouble is that it hasn’t been implemented in Rhino 6.

Hi Wim - here, it seems to be there as a non-autocompleting test command as before. I guess that it not exactly ‘implemented’… but it has not gone away either.


Hi Pascal,
Thanks for setting me straight! Yes, the command is there but it is now working properly. My mind just put it in the “not implemented” category because it cannot be used.



@wim “But apparently at least one user has discovered it and found it to be useful.” i think more users know this command :slight_smile:

@pascal This is ultimate command for showing design on different screen to client while operating on own small screen :slight_smile: And as i said internally it is gr8 for rendering during modeling it helps a lot.

Just to make sure - that’s @dale’s comment. :sunny:

I typically use one viewport in shaded and another one in wireframe.

Hmm - it worked here… I think… checking again… oh, yeah, I see, right, not actually very handy.