Rhino 5 GPU not detected on external monitors

Lenovo P15s Gen 2
11th Gen Intel(R) Core™ i7-1165G7 @ 2.80GHz 2.80 GHz
Integrated graphics Intel Iris Xe
Graphics Card NVIDIA T500
Running 2 x Lenovo screens through a USB C dock via Display Port
All drivers and software updated to latest versions

Rhino 5 running on the external monitors is extremely slow and clunky. The NVIDIA card is not being detected, instead running on GDI Generic.

The Nvidia control panel is set to run Rhino on the GPU, and this works when it is opened from the laptop screen, as long as the laptop is set as main display. Whenever opened from the external monitor as a main display, it reverts to GDI Generic, which is unusable.

I know the Nvidia GPU is functional on the external monitor as the main display, it works no problem with Navisworks and DWG Trueview. It also works for Rhino if the program is opened with the laptop as the main display, and then dragged over to an external screen. This is my current work around which is a pain.

Any suggestions?


View settings when opened from laptop as main display

View settings when opened with external monitor as main display

Hello - I suspect the problem lies here - does it work if you make a more direct connection to the video port?


I haven’t been able to test that yet, need to get the right cord.

But it definitely works as is through the dock with Autocad software.

You’re comparing apples and oranges.
AutoCAD is a DirectX based graphics language application.
Your Lenovo and GPU is intended for DirectX.

Rhino uses OpenGL.

I thought I read in another post that Rhino will be moving to DirectX which could help this situation.

Maybe in the future, but that won’t help Rhino 8 and older.

Thanks all,

Regardless of OpenGL or DirectX, the software is useless when launched from an external display, and perfect when launched from the laptop screen, and perfect when launched from the laptop screen and then dragged onto the external display.

I’ll try bypassing the dock to see if that fixes it. I could run the monitors directly from a USB C to HDMI if that is the issue.

Ever heard of docks causing this before? Display Port vs HDMI, new monitors, or new cables likely to have any impact?

The info given out when it’s “working” on the main display don’t look right. What does SystemInfo actually say?

The T500 has only 4GB of video ram, which for…3 monitors?..doesn’t meet minimum specs. I think those specs are being really conservative, but it’s possibly conceivable it’s not enough–this is the kind of behaviour that was expected back in the days when I definitely didn’t have enough VRAM to run arbitrary numbers of Rhino windows across multiple monitors–if it’s not something about the dock hub setup.

It is supposed to be 4GB, but only showing as 1MB? I actually only use 2 screens, laptop is shut normally. But if I open it, activate the screen and set it as main display, Rhino runs beautifully, on any of the 3 screens. Without doing so, it is so clunky even a blank viewport is slow to zoom in/out.

Can you actually show us the results of the SystemInfo command in Rhino?

It’s probably something about the dock setup, and laptops can just be stupid.

That command doesn’t appear to exist in V5, can’t find anything equivalent.

Correct, the SystemInfo exists in Rhino 6 and newer. The OpenGL screenshots you provided is what we will have to work with.

I suppose for now you’ll have to stick with using the laptop as main display and moving Rhino from that to the external.

I don’t know about Rhino 5 (I started my dev time with Rhino only from Rhino 6 WIP), but Rhino 7 will open on the last display it was closed on, so you could there just keep the laptop display as the main one, then once drag Rhino (7) on the external screen, close Rhino. Now Rhino (7) should open on that screen the next time you start it. Note that this will work properly only if the screen configuration doesn’t change between runs. I use this to ensure Rhino starts on my HUION Kamvas 13 - the same screen I generally show in my streams, even though my main screen is the 4K monitor attached to my RTX A6000.


I tried disabling the Nvidia GPU, Rhino then successfully uses the Intel Iris and runs smoothly again. But obviously I’d prefer to run on the Nvidia.

Yes could leave the laptop as the main display, but that’s painful. I don’t actually need Rhino much, could just do that as needed.

The other thing I tried was setting View/Display Modes/Wireframe/Other Settings/Pipeline from OpenGL to Windows. This improves clunkiness, but loads up the CPU.

Hi Rowan -

This information shows that there is an issue with your OpenGL drivers for the NVIDIA GPU.
Find the latest drivers on the NVIDIA site and install those.

I recently did this mistake. Got a new HP laptop and bought a “HP Universal Dock G2”… turns out, it has a built in graphics card, that’s equivalent to the crappiest old Intel stuff. Worse, if you force your laptop’s graphics card to go through the dock, the video signal gets compressed like a movie, creating massive input lag.

What nobody told me, and what I should have bought is a Thunderbolt dock. (Yes, it’s a thing on Windows as well as Mac which I wasn’t aware of before, and from the sounds of it, neither were you.)

Oh…that explains a lot.

Maybe, but it does all work for other software, so not sure in my case.

I did already update the NVIDIA driver to the latest, not sure why it’s showing up as NA in the Rhino properties.

Here’s another test, disabled the Intel Iris GPU, so now all graphics are running on the NVIDIA GPU. Rhino works beautifully and is correctly picking up the GPU as shown below. I suppose this is a fix, will just chew more power?

Hi @wim,

Not necessarily - Rhino 5 shows NA even when Rhino 7 reports the date and version correctly.