Rhino 5 for Mac WIP Build 5D132w Side panels always open


#1

I usually work with both side panels closed. Evrytime I open a new document or duplicate an existing, the document opens with the side panels open.

the document in front is a duplicate of the one behind.

«Randy


(Brian James) #2

I see that too thanks… filed as https://mcneel.myjetbrains.com/youtrack/issue/MR-2934


#3

Hi @BrianJ one other thing I noticed this morning. If I close a file in perspective view, could be any view but full window maybe, and then I open it in WIP, when I change back to 4 Views they are not centred.

We don’t have a way to reset the views to default on Rhino for Mac, correct?

Thanks, Randy


(Brian James) #4

I’m having trouble reproducing this. Do you mean the model is not centered in the viewports as it was when you closed the file in 5.2.3 or that the viewport aspect ratios are not the same? The sidebars play a role in the viewport sizes too so I compared with the same settings. The 4View command still hasn’t been implemented… https://mcneel.myjetbrains.com/youtrack/issue/MR-292 but hopefully it can be at some point. This is the only way I know to restore the viewport aspect ratios to defaults. But you can center a model by ZEA at any time as I’m sure you know.


#5

I use Ze & ZEA a lot. Not the model. I closed a model with just with the perspective viewport open. When I open it and then hit the little “4 squares” icon in the viewport tabs the model opened like that. I never adjust my viewport ratios, so I found it odd.

It may be my computer, I just opened WIP again and now my OSnaps are not working. Maybe I will do a restart

I was trying to do a line angled from and it won’t let me select any oSnap, cursor moved when taking the screen shot.

Thanks Brian,

«Randy

Computer info …

Software information

Software versions
Rhinoceros version: 5.3 WIP (5D132w)
IronPython version: 5.1.2015.131
Language: en-CA (MacOS default)
OS X version: Version 10.12.1 (Build 16B2555)

Plug-ins
/Users/jp-rhino3/Library/ColorPickers/SkalaColor.colorPicker/Contents/MacOS/SkalaColor

Third party kernel extensions
at.obdev.nke.LittleSnitch (4718) 715E9654-C3FB-39A4-9514-C770F749EE8E
com.intel.kext.intelhaxm (6.0.1) 8FF2C637-0A5E-367E-B007-5B08655B1E8A
com.getdropbox.dropbox.kext (1.8.1) 81F3EECE-2B2A-35D5-A57A-62066A404BFC

Hardware information

Computer hardware
Hardware model: iMac12,2
Processor: Intel Core i5-2500S CPU @ 2.70GHz
Memory: 20 GB
Architecture: Intel 64 bit

Video hardware
Graphics: AMD Radeon HD 6770M 512 MB
Memory: 512 MB
Screen size: 2560 x 1440, 1440 x 900
Displays: iMac (109dpi 1x), SyncMaster (89dpi 1x)

USB devices
Apple Inc.: FaceTime HD Camera (Built-in)
Microsoft: Microsoft 3-Button Mouse with IntelliEye™
Apple, Inc: Apple Keyboard
Apple Inc.: Bluetooth USB Host Controller
Apple Computer, Inc.: IR Receiver
Apple: Card Reader

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 ATI-1.46.22
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 4x
Mip map filtering: None
Anisotropic filtering: None


#6

fwiw, these issues (the weird 4 view & side panels staying open) have also been reported by multiple users in this thread:

there are 4 or 5 separate issues being discussed in that thread but i believe dan is aware of the ones in this thread.


#7

Thanks Jeff, we’ve been living with all kinds of Rhino for Mac weirdness for the last 8 years or so, I still get work done. I still have some pink icons on my El Capitan Rhino at home :smile:

@Brian I see the same issue over on the thread @jeff_hammond mentioned. I will continue there. thanks!

Is the same issue I described.


#8

ha. i have quite a bit of Rhino work to do this week.
maybe i should turn off my wi-fi connection for a while :slight_smile:


#9

Hi Brian
I think I’ve identified the responsible for the problem.
Moom application.
I was able to reproduce the behavior of the windows with active Moom. With Moom disabled the problem disappears. At least for me it is.

Simon


#10

Not Applicable here, since I don’t have that app. Thanks though, it all helps.

«Randy


#11

:frowning:

If you have not already done so, I would advise to try to disable any applications running, and see if the problem persists.


#12

I’ve seen this too.

Philip


(Dan Belcher) #13

This issue should be fixed in the next RhinoWIP (forthcoming). Thanks for reporting this!