How to switch between viewport?


#1

Hello,

I’m wondering if there is a way to switch between a “fullscreen” viewport, or maybe the corect terme is maximized viewport.

In windows I’m doing it with the shortcut ctrl+tab, but it doesn’t work in my mac version. I also try the nextvieport option, but after a few switch, it goes back to the forth viewport option.

So if you a a solution, I would be really thankful !

Best
Damien

(I’m using the 5.3.1 version of rhino in macOS sierra, on a macbook pro)


#2

NextViewport switches sequentially through all views and cycles them just like in the windows version. i am not sure anymore if i activated that myself since i use the middle mouse button for this, but in just in case go to the rhino preferences -> commands -> customize, then in the search field below you search for next viewport and assign the short cut, if its not there yet you can also make one yourself by pressing on plus and name it so with the command in the script field.

the same is for PrevViewport


#3

are you looking for a keystroke only method? if not, you can click on which viewport you’d like at the top of the window.

in that image, perspective viewport is maximized… if i click on ‘Front’, the front viewport will be maximized instead.


#4

Thanks for your advices !

Yes I’m looking for an keystroke only method.
I try RchardZ proposal, but I can’t stay in a maximized viewport for more than three switching. Then it automatically goes back to the four viewport view.

I’m also trying to ajust the shurcut and mix it with maxviewport, but without success up to now.


#5

Hi
Cmd + f1 / f2 /f3 /f4
depending on which view you want.
[if your MBP is set for the default function, you’ll need the Fn key as well

HTH

akash


#6

hmm. i’m not sure then… NextViewport works ok for me on my computers. i can use the command many times and it will not switch to four views.
?


#7

I’ve done this by assigning following hotkeys and it works really well:
"§" - toggle between 4view and maximized
"1" - maximise perspective
"2" - maximise top
"3" - maximise front
"4" - maximise right

You can do this by going to “Rhinoceros” > “Commands” > “Customize…”

Search for “viewport” in the bottom search box and assign hotkey to desired function.


#8

hi Stefan
that is surely the handiest way,

I tried to add bottom, back and left with but
Rhino says: Unable to find viewport named {one of the above}
wanted to add these as 5 , 6 & 7 hot keys,

is there a way to do that?


#9

It seems better to add a modifier key to the number, to avoid confusing Rhino.


#10

I suppose you can assign hotkeys to manipulate the view in addition to changing actual viewports. Try by searching for “set view” or similar…
Regarding modifier keys, yes. For me personally just §,1,2,3,4 works fine since I don’t use any functions that begin with those characters, at least for the time being…


#11

You can add
!_NextViewport
in Keyboard Shortcuts. Eg. for ⌃⇥, so it works like it does in the Windows version.


#12

Hi Ties
have you tried this, more then one cycle? …

the thing is that currently, [latest WIP] it work fine though the 4 v. ports, but then [as mentioned earlier in this thread]
it gets bogged down in the 4 view button and from there the command will only circulate the active port within the 4 view.

This feels like a bug not an intended behavior.


#13

The Italian keyboard, as by default it already works cmd + ’ to move in the windows of Rhino, I assigned alt +’ for NextViewport.


#14

Hi Akash,
I do not use the 4 small viewports in one window very often. When I use it, I don’t mind to click the button top left to switch from maximized viewport to small. Once back in maximized, I use my shortcut again to cycle through them.

Do I understand it right when I say you’re looking for a way to include the 4 small viewports within the cycle of maximized vieports?


#15

Hi Ties
i may have not been clear enough with my english,

i too rarely use the 4 small views. what was said is that when you are in max view, and cycle with the shortcut: once one cycle is through, the command jump into the 4 view condition and get stuck there. only circulating active view within the small 4…
don’t you have the same issue on your machine?


#16

Hi Ties and Akash,

As Akash explain, the cycle end after a turn and get block in the 4 small views…
then I wonder if it’s a bug or a possible configuration.

So by know I’m using the numpad to switch between views, as it has been suggested by stefannysten, so thanks !
It’s an alternative, I wasn’t using maximise, but only view top, witch was creating some troubles then with ctplanes, and différents viewports.


#17

Akash, Damien1,
Strange, I don’t have this behaviour. For me the small viewports are not included in the cycle.
So it sounds as if it’s a configuration issue…?


#18

Hi Damien
the limitation i have with the keys shortcuts is that they only work for the default views.
and if i have for example Left view, i’m unable to assign a key shortcut to it.
perhaps you know how to?

with thanks
akash


#19

Hi Ties
i wonder what is different [better :}~*] in your rhino,
there are no setting related to this that i could find,

any idea?


#20

Did you enter the same customisation?