Revit for Rhino >>External Tool Failure: System.Reflection.TargetInvocationException<<

Hi All,

Just downloaded the plugin from food4Rhino and receive this error message. Help please.

Error Message:


Hi Jia Yeap,

I’m getting the same error message.
I’m using:
Rhino 7SR14 (7.14.22010.17001.2022-01-10)
Revit 2021.1.5
Rhino.Inside v1.0

I also try to launch grasshopper in Rvt 2019 and there it did work properly.

Agni M

Interesting, the process below usually fixes this error but I’m wondering if it has something to do with 2021.1.5 in particular. Give this a try and let us know if the issue persists. Thanks.

  1. Make sure Revit is closed
  2. This step is quite important: Uninstall any previous versions of Rhino.Inside.Revit through Windows Control Panel > Programs & Features
  3. Download the latest Rhino.Inside.Revit
  4. Install the new Rhino.Inside.Revit. with administrator rights.

Thanks for your quick response.
I already tried that process before and in my case it didn’t work.

However I found what was causing the issue. I had an another pluggin, ‘Unitize’, probably that dll file was conflicting with Rhino.Inside.
I did disable ‘Unitize’ by using ‘Stantec Adding Manager’.
The app is downloadable from the link below:

Creating a safe mode to diagnose Revit add-in issues (

Thanks for the update! That was our next troubleshooting step, glad you were able to figure it out so quickly.