Revit 2020.1 Grasshopper inside revit issues

Hello RiR team,

I am having issues with the rhino inside technology and Revit 2020.1

I used the typical RiR installer on my machine and seemed to install with no issues. I fire up Revit and Rhino inside as well Grasshopper with seemingly no issues either.

Once I start dropping Revit components onto the canvas I noticed all of my components are erroring out wit the same message:

"1. Solution exception:The input argument “document” of function `anonymous-namespace’::FilteredElementCollector_constructor or one item in the collection is null at line 326 of file d:\ship\2020_px64\source\revit\revitdbapi\gensrc\apifilteredelementcollectorproxy.cpp.
Parameter name: document"

When I reference in rhino inside geometry into Grasshopper, the previews seem to be working fine. It seems that partial functionality of RiR is missing for me

I am currently trying to have a look into the source code using visual studio and rebuild it myself. I have not gotten any results so far except that the VS solution doesn’t seem to be picking up on the Autodesk namespace. I will investigate further but would like to get some insight from the Mcneel team.



Have managed to successfully build using the Debug2020 configuration and targeting 4.6.1 to no avail :frowning:

Have just tested Rhino Inside for Revit 2018 on my machine. Exactly the same error for almost all components. There must be a consistent issue with my machine. Unsure how to continue debugging.


There is a new installer.
Could please test it and tell me?


Thank you for the timely response. I have just re downloaded the installer and it works!

Could you please let me know where this issue was stemming from if thats ok? In the future, I look to contribute to the rhino inside project and am curious about what happened.


Trying to fix a problem for a user I broke the general case. :pray:

I did a change in the way Grasshopper loads RiR assembly that only works for developing purposes.

had the same problem after updating rhino wip but works now with the new installer thanks kike for all your efforts