Naked edges on mesh driving me mad

Hi guys,

I’m struggling a lot with a mesh model I made. I created the orginal 3dm model in rhino, exported it to zbrush so I could create a very organic texture on the outside of the ring (I’m a jeweller) and now when I’ve imported it back into rhino to add to the model, it is a mesh that even when I join the edges has over 4000 naked edges :weary: I can’t manually join them for obvious reasons, I have tried, rebuildmesh, unifymesh, repairmesh and many other things without success. I am a self taught CAD modeller, I’m compentent with modelling polysurfaces for STL but am out of my depth with meshes, please help!

Ring for Forum.3dm (11.5 MB)

I don’t know if it is possible, but if you could share your mesh model, that would enable others to try and see if they can help you. You can upload the model to this topic using the upload button in the editor (arrow up)

Thanks for your response. Just done that so you should be able to check it :slightly_smiling_face:

So, there was quite some problems here, but they could be fixed quickly using the following approach:

  1. remove the bridging meshes between inner and outer parts.
  2. duplicate the borders of the non-flat part, and use MeshPatch to create a new bridging mesh. Split the resulting mesh (using MeshSplit) with the inner and outer border curves to get the non-flat part and join the three parts.
  3. Use SelNakedEdgeMeshPt to select the naked edges on the flat part. Use SetPt to align all points on the same Z-coordinate.
  4. Use the same procedure with the border curves, MeshPatch and MeshSplit with border curves to create the flat bridging mesh.
  5. Join everything to get a closed mesh (see attached).

Ring for Forum_CLOSED.3dm (11.8 MB)

MatchMeshEdge at .01 does some good too, but there is a bit of cleanup needed still.


Thanks so much for your super quick response and sorry for the problems with the model. Sadly I can’t open that file, it must be in a newer version of Rhino than I currently have, I have version 5.

(Point 3) I have removed the ‘bridging meshes’, duplicated the borders and used MeshPatch to create the new bridging mesh and joined, but it seems that there are still naked edge points all along the top edge as well as the bottom, as you can see from the images below.

If I move on to SetPt then as you can see below it selects all the points…

Thanks for responding Pascal but MatchMeshEdge doesn’t do much for me, when do you suggest I run that command?

Ring for Forum_CLOSED_v5.3dm (11.6 MB)

This is the same file but saved in Rhino 5 format.

In the SetPt step, you should allow points only to set the Z-coordinate. Also, I can’t see very clearly in the pictures but it looks like you have skipped this bit after the MeshPatch command:

Split the resulting mesh (using MeshSplit ) with the inner and outer border curves to get the non-flat part and join the three parts.

Yes I can open that file, thanks for that :pray:

Still struggling though with doing it myself. Yes I did follow the SetPt step, I then used the inner and outer curves as you said to split the mesh and remove the access and deleted that (as shown in below pics) I accepted the default AngleTolerance of 15 during the MeshPatch command, not sure if that effects things… but it still leaves naked edge points all the way along the newly joined edge and obviously the bottom edge where I haven’t rebuilt the ‘bridging gap’.

Excuse my inexperience if I’ve misunderstood this but the geometry/polygons on the unflat bridging gap mesh look very different to the polygons on the textured front of the ring. Is it possible that because the geometry is different on the different parts of the model, when I run the Join command rhino is struggling to match up the all the edges of the mesh polygons? This might be what @pascal was getting at with the MatchMeshEdge command?