Jagged edges even with smooth and slower mesh settings

Hi, problem with jagged edges is pretty common, but the ususal solution switching meshes to “smooth and slower” does not work for me. I even changed it to custom and pushed density to max, still does not help. I tried also smooth command.

The scene is made completely in rhino, there are no imported meshes or anything. I have made most of my meshes by extruding curves or making planaro surfaces of closed curves. There is a lot of curved and smooth objects in my model, some of them appear smooth, some of them obviously jagged.

Could someone give me an advice how to fix this, please?

Hello - there are more settings available, but at a guess, I’d try DivideAlongCreases with ‘SplitAtTangents’=Yes and then select your object.


Wow, thanks a lot Pascal!
This command worked indeed. I can still see the edges in the model if I zoom in, but the rendering result is perfect.