Restore default lighting and materials


#1

How can I restore lighting and materials to default “out of the box” settings?
Since importing a few SolidWorks files, everything looks sort of wonky.


(Pascal Golay) #2

Hi Steve - importing SW files should not make a difference to Rhino’s setup, but you might have some off layer colors or materials coming from SW. You can select all and set material, and Display color, to By layer (Properties) and set layer materials to use Default Material. Does that help at all?

-Pascal


(John Brock) #3

You’re making the assumption that the lighting and materials have changed to create the unwanted effect you’re trying to fix.
How about post a small file and an image that clearly shows the problem you’re trying to fix?


#4

Material and display color are by layer, and all layers use Default Material.
Everything look a little too metallic.


#5

I don’t think an image will help, because I don’t have a “before” picture to compare to. Everything looks a little too metallic or glossy. I didn’t change any appearance settings, as far as I know.


(John Brock) #6

Is your perception relative to how it looked in V4, or how it used to look in V5 before something changed?


#7

V5 before something changed. It seemed to change following import of a SolidWorks file. I even tried reinstalling Rhino, but the problem persisted thru an uninstall/install cycle.


(John Brock) #8

OK.
As Pascal said, there isn’t anything that importing or opening a SW file can do to change your display settings, but it sounds like something changed.

Go into the Options command - View - Display modes.
Do any of the mode names display in lavender? If so, this means that working display mode has been modified and is not default. Go into the settings of the ones that are lavender and click on the ‘Restore Defaults’ button. This will reset the information in the named display mode and the name with switch back to black.

Please give that a go.


#9

None of the mode names display in lavender.


(John Brock) #10

Here’s what a sphere looks like on my system in a default Shaded display mode:

Is this the “metalic” look you see?

Here is what V5 does with the Shaded display ‘Color and material usage’; setting changed from ‘Custom material for all objects’ to the more V4 like look of ‘Object’s color’.


#11

I’m in ‘Custom material for all objects’ mode, and seeing this:


(John Brock) #12

That looks like mine except you’re using a black background.
Why the black?
Did you try the Object color option?


#13

I prefer the black background, because I’m usually working in wire-frame mode.
Here is a side by side comparison of what I’m seeing (left) and the same object on a different PC without the problem. The image on the left seems too contrasty or too shiny.


(John Brock) #14

You might try the Rendering material setting, and switch to ‘Default lighting’ to really flatten it out.
Other than experimenting with the settings, I don’t know what else to suggest.


#15

That is what software OpenGL looks like.
I see you have no AA on the lines as well.

Check to see if Rhino has disabled your hardware OpenGL acceleration:

I presume you have an integrated intel chip or an ATI graphicsollution.


#16

Thank you, that fixed the problem.