Error displaying object colors by layer when in 'shaded view'


#1

Essentially when I’m working in shaded view all objects are a dark gray despite the layer colors being different. The only relation to layer color is an outline around the object. I don’t recall having this problem not too long ago. I’ve tried tampering with the settings and resetting the shaded view settings back to default but to no avail. Running Rhino 5 on Windows 7.

Same problem as this user – Shaded display view is way too dark

I’ve attached screen shots comparing shaded and ghosted views. Seems to work fine in ghosted. Also excuse the terrible graphics card on my laptop. On that note, I don’t have this problem on my desktop (iMac running Windows 7).

Would appreciate anyone shedding some light on the problem. It’d make working on my laptop much more convenient!


(Pascal Golay) #2

Hi Anthony- my first guess is the shaded display mode has been tweaked - if you open Options > View > Display modes, is the Shaded mode shown in blue text? If so, any specific settings that are blue are non-default, most likely ‘Color & Material usage’. One quick test would be to click on ‘Restore defaults’.

-Pascal


#3

Hi Pascal, nothing was in blue no and it seemed like it was actually set to default. However under the ‘default’ settings Color & Material usage was set to ‘Custom Material for all objects’. I’ve changed it to ‘Object’s Color’ and all seems to be working fine, so thank you for bringing this setting to my attention.


#4

Hi mcanthonyy, @pascal, @vida

Default Shaded mode does not reflect color from the color picker, even when working with ‘Flat shading’ and in 2D.
To get a good reproduction of the colors, I use indeed
Color & Material usage = Object’s Color
Gloss = 1

The following image is with Default Shaded mode:


#5

This is normal, there is default lighting illuminating the surface, it’s not a flat color…

If you need areas of flat color for 2D plans, use solid hatches instead of surfaces.

If you need surfaces to have a flat color in 3D (rendered mode):

  1. apply a material with the desired color, no gloss, no reflection, no texture, nothing but the color
  2. then under that material go into “Advanced settings” and uncheck “enable diffuse lighting”

HTH, --Mitch