Repeat or loop complex command from macro editor

#1

Dear Everybody
on Rhino for windows i can use the macroeditor to - for example - loft a surface, select the result and lock it:
`-_loft _enter _enter _selnone _sellast _lock
now i can press spaceto repeat this command-combination.
this does not work on the mac version
the mac version will just repeat the “_loft” part of the macro
how can i have the same functionality on the mac-side?

there is a old topic about a similar issue - but this is just about automatically repeat a command (without pressing space), and it is not solved

@pascal
still no Calvados no Stella and no Perrier…

best - Tom

Rhino 6 for Mac WIP build 6.15.19106.13406
(Graham) #2

Sounds like a job for Python scripting to me
Try it - it’s great !

#3

Dear Graham
thanks for having a look at my question.
i need a solution, that i can show my students, that use Rhino since 5 days and do not have the background to start programming - they do an apprenticeship in a pottery-Workshop.
I am a bit angry (on mc neel) for a lot of smart things regarding the UI that work on the Windows side, but not on the Mac side…and of course, nearly every feature can be solved with phyton or (i prefere:) c#…
thanks so fare
tom

(Graham) #4

Ahh yes I see : that’s quite frustrating :slightly_frowning_face:
:thinking:
:slightly_smiling_face:
Copy and paste ?

(Pascal Golay) #5

Got that, thanks.

https://mcneel.myjetbrains.com/youtrack/issue/RH-51349

-Pascal

#6

It works when you make an alias for it, say a single character like an “I” for instance.
pressing the spacebar will repeat the “I” and thus repeat the macro behind it.

Max.

#7

Dear pascal and @maxz
thanks for tracking and thanks for the workarround.

@pascal
there is another “ugly” issue:
if you assign an alias and for example i love: m for move and c for copy
and i want to use the command _mirrow - i have to type the the underscore _ othwise - as soon as i type m it becomes a move command that is fired.
also this is different to the windows version - where i have to press m + space before i fire the command
while on the mac side already the m on it s own will fire the command…
and for the c there is curvaturegraph and others…

thanks and good night
tom

(Pascal Golay) #8

Hi Tom - as far as I can see on Rhino 5&6 for mac it behaves as on Windows - M by itself, without an Enter or space, does nothing but suggest M at the top of the command list. If I then type an ‘i’ I see Mirror in the list… am I misunderstanding the process you’re describing?

-Pascal

#9

my rhino version: 5.5.3 on mac os x 10.10.5
(1)
set up m as a shortcut / alias for _move
(2)
now pressing m will fire move-command
???

(Pascal Golay) #10

Hi Tom, so that would mean you could not run any command that starts with ‘m’ other than Move- is that the case?

This is where you set this up, correct?
image

-Pascal

#11

no - i set it under Keyboard shortcuts
(and i change language depending on the class i am teaching… that is why you see the german verschieben)

#12

ok - let s skip this second aspect - it works as expectet when set up as alias.

(Pascal Golay) #13

Hi Tom - keyboard shortcuts indeed run as is - on Windows you do not get to use plain letters, only f-keys and modified letters … I would use an alias here…

https://mcneel.myjetbrains.com/youtrack/issue/RH-51350

-Pascal

#14

…still some work to make the mac and windows experience comparable…
i teach classes with both mac / pc and that is not a fluent experience to have both “worlds” at the same time.
i do videos and tutorials - often twice the work…
but many thanks for the fast clarification

(Dan Belcher) #16

RH-51349 should be fixed in the latest RhinoWIP. Please give it a try.