Renderings have low CPU/GPU usage on my PC

Hi,
I’m just wondering why Rhino Renderer isn’t taking the full advantage of my specs,
As you can see there is no high CPU or GPU usage when rendering.
and most of all, renderings takes so long on basic geometries, and simple scenes ( nothing fancy ).
So what’s the matter?

system info

Rhino 6 SR12 2018-12-17 (Rhino 6, 6.12.18351.21491

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

Hybrid graphics system.
Primary display: Intel® HD Graphics 530 (Intel) Memory: 1GB, Driver date: 11-11-2016 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 960M (NVidia) Memory: 4GB, Driver date: 11-2-2018 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 416.81

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-2-2018
Driver Version: 25.21.14.1681
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
D:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.12.18351.21491
D:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
D:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
D:\Program Files\Rhino 6\Plug-ins\RhinoLabsTools.rhp “Rhino Labs Tools”
D:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
D:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
D:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.12.18351.21491
D:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Users\SAAS\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.10.11.800\PanelingTools.rhp “PanelingTools”
D:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
D:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
D:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.12.18351.21491
D:\Windows Files\AppData\Local\Enscape\Bin64\Enscape.Rhino6.Plugin.dll “Enscape.Rhino.Plugin” 2.3.18222.855
D:\Program Files\Rhino 6\Plug-ins\Penguin 2.0\Penguin.rhp “Penguin 2.0”
D:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.12.18351.21491
D:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
D:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Users\SAAS\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2018.8.24.259\SectionTools.rhp “SectionTools”
D:\Program Files\Rhino 6\Plug-ins\NamedPositions.rhp “Named Position”

Rhino Render doesn’t use the GPU at all, but in Tools > Options > Rhino Render Options you can set it to use a specific thread count and thread priority. See if that helps. Note that using as many (or more) threads as you have logical cores will make your machine prone to unresponsiveness, especially if you use higher thread priority.

1 Like

I checked it, and all have already been set to the highest values, 8 Threads ( maximum for my CPU ) and “Thread priority” set to “Highest”
and somehow I hit render today and it takes 100% usage of my CPU.
It’s working.
Thanks Nathan!

Remember that setting higher-than-normal priority for the threads can make your machine unresponsive while rendering.

1 Like