Preformance drops, CPU/GPU not heavily utilised


(Simon) #1

Hi,

I’m on windows 10, rhino v5.

I’m just wondering, especially when I’m working with very big/very detailed models, the performance/framerate of the program slows down considerably. Even though my CPU is only taxed at maybe 20% at the very max. GPU hardly moves away from 1%.

This doesnt make sense to me. Can someone explain this to me?

Edit: I just realised, I should look at single core performance as well. When working in this file, there is one core at exactly 50% utilization. What does this mean?

Edit2: I was looking around in the options for some sort of quality setting, but couldnt find it. But I did find within Rhino Render Options the settings for Multithreading. Can someone recommend a safe setting for my processor: Intel i7-6700

Edit3: CPU doesnt seem to be throttling

Thanks in advance.
Simon.


(Pascal Golay) #2

Hi Simon - it would be interesting to know if the same model behaves any differently using the V6 Eval ( https://www.rhino3d.com/download/rhino-for-windows/6/evaluation ) . Can you post an image of Options > View > Open GL page in V5 and if you decide to try 6, run the SystemInfo command and paste the results here…

-Pascal


(Simon) #3

Hi Pascal,

thanks for your response. I’ve made a screenshot of the OpenGL settings

I’d like to try Rhino6, I’ll see if I can get around to installing it. Thanks for the link, I didn’t know there was an evaluation version.

Meanwhile I already changed the Thread Priotity to highest in Rhino Render Options, and that helps alot. Although I didnt run any other resource intensive software alongside Rhino today. So I might need to back that down again a few notches if there are any issues.

Wondering about the number of render threads. Any advise on this?


(Pascal Golay) #4

Hi Simon - I tend to set the number of render threads to one less than the max, so that there is a chance I can do something else while a large rendering is churning.

Not specifically rendering related, but display related - you might check the NVidia website for their latest driver.

-Pascal


(Simon) #5

hmmm,

Do these options only apply when making a render of the model? Then I must have felt a placebo after I set it to Highest. I never make renders of my models, I just the models for CNC’ing.

I thought these where more general rendering options. As what you see on the viewports… (I’m sorry English is not my native language, I’m missing some of the vocabulary :))


(Pascal Golay) #6

Hi Simon - the video card does not contribute to the Rhino renderer (though it can to the Cycles raytrace mode) and Rhino render settings for the threads used etc have no impact on the viewport display.

-Pascal


(Simon) #7

I just installed V6 for evaluation.

It seems to be running a bit smoother, but I still need to do more testing. Also need to import my settings from V5 still.

Here’s the systeminfo output you requested.

Rhino 6 SR10 2018-11-7 (Rhino 6, 6.10.18311.20531, Git hash:master @ 0f9089a0035dcc6955732d57071445ecc29390f0)
Licence type: Evaluation, build 2018-11-07
License details: Cloud Zoo.  In use by: Simon ()
Expires on: 2019-03-06

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: PNP-WS2

Quadro K2200/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 388.16)

OpenGL Settings
  Safe mode: Off
  Use accelerated hardware modes: On
  Redraw scene when viewports are exposed: On
  
  Anti-alias mode: 4x
  Mip Map Filtering: Linear
  Anisotropic Filtering Mode: Height
  
  Vendor Name: NVIDIA Corporation
  Render version: 4.6
  Shading Language: 4.60 NVIDIA
  Driver Date: 10-30-2017
  Driver Version: 23.21.13.8816
  Maximum Texture size: 16384 x 16384
  Z-Buffer depth: 24 bits
  Maximum Viewport size: 16384 x 16384
  Total Video Memory: 4 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp	"Commands"	6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp	"Renderer Development Kit"	
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp	"Rhino Render"	
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp	"RDK_EtoUI"	6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp	"Renderer Development Kit UI"	
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp	"Snapshots"	
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp	"RhinoCycles"	6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp	"Toolbars"	6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp	"3Dconnexion 3D Mouse"	
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp	"Displacement"

(Pascal Golay) #8

Hello - make sure to keep your video drivers up to date - yours are probably fine but over a year old, it might be time to check the NVidia website for the latest.

-Pascal


(Steve Baer) #9

SR12 may help here. There were some recent fixes that should improve performance with “heavy” models