Rendering object reflection/shadow without object?


#1

How do I get a render output where the objects in the model are essentially not visible/hidden but their shadow and reflection on the ground plane are showing in a separate channel?

** Tagged in Scripting because I’m looking for a scripting solution.


(Dale Fugier) #2

Moved to the “Rhino for Windows” category, as you’ll find more rendering experts here.


#3

Per Vray? Enable “only in secondary” at the material options.


#4

Thank you @Micha ! That works fine, but I realize this does not really ‘catch’ the shadow/reflection in a separate channel as in my alpha channel is empty. Is there is a simple VRay options solution for this or will I have to implement a shadow/reflection catcher?


#5

Maybe it helps if you use the wrapper material for the ground.


#6

@Micha Also related, do you know if there is a setting for controlling reflection such that if there are a couple objects in the scene (with reflective materials), I don’t want the objects’ reflections to show on any of the other objects’ surface. I only want the environment reflections to show on the objects. Is that possible?


#7

Material option “ignore objects in secondary” could help you.


#8

Thank you, @Micha! Just what I need!


#9

Hi. I have your same problem. I would like render an object with its shadows, but just that without other materials, like the image in attachement. I read also about the use of Dome light, but I would maintain my light set. I’m a vray beginner. Could you explain step by step how an I proceed? Thank you so much.


#10

@Max1 In order to get the shadow in your alpha channel, you need to use a shadow wrapper. Here is how to do that:

In your VRay Material Editor, create a VRay Wrapper Material. Do the following in the wrapper material’s settings:change the base material to the material that’s applied to the ground plane; enable ‘Affect Alpha’ and ‘Shadows’ and set the alpha contribution to -1. Finally, apply the wrapper material to the ground plane.

Here is a pretty helpful video by @Fernando_Rentas showing what I explained above: https://www.youtube.com/watch?v=tKS9U93HvTM


#11

Thank’s for your instructions. After this I have to compose the alpha channel in photoshop? Please, could you explain how compose in phtoshop to obtain my needs? thank you

I see that in that video the author creates a dome light to use wrapper material. I have a light set-up yet, and can’t use dome-light setup. How can obtain the same result without using dome-light?


#12

I use the shadow wrapper all the time without a dome light and it works for me :slight_smile:


#13

Yes, you’d have to compose it in Photoshop. I’m not a Photoshop expert but what I do is save the ‘shadow pass’ render (the shadow as obtained above) as a targa file. Then in Photoshop, I go to channels and do Ctrl + Click on the Alpha channel which selects the shadow and then paste it in the document which has the object image.


#14

Ok. Thank’you. I did it. It works fine! :blush:
i have just another question. If I render the scene with a visible white ground (by a standard material, not wrapper), the shadows are just a little colored by the color of object. If I render the scene with a wrapper material applied to the floor, and I save the render of the object as a targa file, with alpha channel (that contain the shadows) and compose them in photoshop, I obtaine the same result for the shadows (even if in the composition the ground floor is transparent) but shadows are not colored, are just in grey gradient. Do you know why?
Thank you so much for your time!


#15

@Max1 Is this what you’re looking for? http://www.workshop.mintviz.com/tutorials/matte-shadow-and-reflection-using-v-ray-2-0/

(the above uses the VRayDirt Material as a texture to get the reflection in the alpha)