Rendering dimensions and text


#1

Sometimes I want to render the dimensions of objects, for instance when sharing drawings with machinists.

To do this I go to Render/Render Properties/Toucan Render. I then check “Render dimensions and text”.

However, this does not seem to work. The dimensioning lines never render.

I also do not understand what “rendering text” means, since whenever I create text it is always as solids, so obviously those would render. What would text look like in order to need the command “Render dimensions and text”?

What am I doing wrong? What should I do to render the dimensions?


(John Brock) #2

“Rendering” implies making an image from something that displaces volume and area like solids and surfaces. This is why the solid object you make that look like text actually render.
Lines, curves, and dimension objects don’t have any volume or area so by default they do not appear on a rendering.
The option to “Render dimension and text” is a post rendering process that superimposes pixels used to see these non-rendering objects, and make them part of the final image.


#3

So my question is: How do I do this?

How do I superimpose dimensions on my already rendered objects? I want to make certain dimensions part of my final image. How do I do this?


(John Brock) #4

Hi
You’ll need Windows Rhino. This feature isn’t implemented in Mac Rhino yet.
After your message I tried it myself using both Toucan and Rhino Render, then followed up with the developer. They are on the list to be done but not done yet.


#5

Thank you John.

Sometimes it is clear when a command is not implemented yet, because a window will pop up saying so. That was not the case with rendering dimensions and text.

I’m glad to know that is was not me doing anything wrong.