Render window always opening in transparent background mode

I’ve got another little glitch with iRay in the last few Rhino versions…the render window always opens up in the “Show RGBA channel” mode instead of “show RGB channel.” Why might that be?

That is done on purpose, it should be fine to do just that.

If you get alpha channel set in your final result you’ll see it better. If there is no alpha component set it should look like it did with just RGB. Showing RGB instead of RGBA confused users more.

Users doing what? I’m doing “product” renders with the background replaced using wallpaper, I don’t generally care what the alpha channel actually “looks like,” I just want the result, it’s What You See (in the iRay ratraced viewport) Is What You Get (in the Render Window.)

Do you have transparent background checked? If so, uncheck it. You should see what you have in the viewport.

Yes I have it generating the alpha channel if I want to edit it. That doesn’t mean I need to see it every render, this is not something I’ve ever thought of needing in 20 years of using the product.