Rendering with alpha channel

I"m attempting to render an object, Rhino default renderer and default lighting, no background and an alpha channel. I’m finding no option to render with an alpha although I do see the “show alpha” button in the render window. How do I do this? Thanks

Rhino Options - Rhino Render - Cleck Transparent background.
Then Render and save as a PNG file

Here’s a screenshot too…

Hmm… I’m trying to do the same thing and it’s not working.

  1. I have Auxpecker 2.0 installed, but the Background is not active (Slider turned off).
  2. Viewport Display Mode is set to Rendered, not Auxpecker.
  3. Current Renderer = RhinoRender.
  4. Options/Doc Properties/Rhino Render > Background = Transparent.
  5. I am using .png or .tif format.

My viewport has a solid black background, and so does my ‘printed’ .png file.

Any suggestions? I really need to get this sorted out…


I don’t have Auxpecker here but if it’s not active as the Display Mode on your system I’m not sure how it would play a part in this. Have you tried disabling the plugin as a test anyways? If it still doesn’t work, can you share the file or a portion of it?

Ok - I found the problem. I was trying to use Print to export the viewport as a png. This method ignores the “transparent background” options.

If I do a formal Rhino Render, and save as png, I get the transparent background. Unfortunately, I don’t want to run the Render engine, as Auxpecker already has eMaps applied that look pretty good. See attached for the difference.

Is there a way to get an alpha channel using just Print>PNG, or CaptureV iewport?


Use “-ViewCaptureToFile” and change the transparent background command line option to yes. This should work for you if there’s nothing under the model like a ground plane.

Awesome! Thanks Brian, that works great. The Command Line interface is a little clunky, but it works!



Just to followup, I find myself using this pretty frequently. Is there any plan to streamline this process? I ask because the command line offers Width/Height resolutions, but

a) I am not sure of the ideal aspect ratio
b) I often could use a draw-window similar to the print command.

Thanks again!


The aspect ratio appears to default to your viewport ratio. The “multiplier” option then scales the resolution by that ratio x the scale multiplier you type in. If I want a specific resolution (ie. 4:3 or whatever) I think you have to do the math manually first.

I believe in Vray you can bring up a red square that shows the render preview space? Is that what you are thinking of?

That’s great to know what the multiplier does! :wink:

I’m not familiar with Vray, so I can’t speak to that preview, but I might not need to render the entire viewport, so I would like to draw a window around just the relevant area.