Save alpha channel changes now background renders as black?

Hi,
When I render with “transparent background” checked (in the Render Tab) the background does not render but renders as black. Maybe I’m not remembering correctly but I recalled last wip we could render with transparent background checked and Rhino would still render the background. Then when we saved the image checking alpha (the option under the rendered image when we save it) Rhino saved the image without the background and unchecking save alpha saved the rendering with the background rendered.

Am I remembering correctly? Now I have to render twice once with transparent background checked and then again with it unchecked.
RM

It has been like this since the beginning. This is also how Cycles in Blender renders when transparency is set for film.

Ok thanks I must be thinking of 3dsmax I go back and forth. Might be a good idea don’t know if it’s possible but it would save me an extra rendering which is huge, Max has that feature why not have it in Rhino? I don’t see why it renders black if save transparency is checked. Plus if you uncheck transparent background in the rendering tab and still have it checked in the save rendering dialog box it doesn’t matter but might lead to confusion. Maybe for consistency this should be uncheckable or greyed since it doesn’t work in that case. Also the ability to save post fxs and still get alpha channel export would be great.
RM