Render Viewport not showing shadow

When I click the top left “interior” button to the rendered viewport it comes off like this instead of being shaded and have shadows. Also if I put it on the shaded setting the entire viewport goes white and I can’t see anything. Please help!

Hello - it looks like you have ambient light set - try restoring the Rendered mode to defaults in Options > View > Display modes.

It could also be that the objects have materials with ambient color or diffuse lighting off: