Render mesh issue

Hi all,

I cannot seem to get rid of the Render Mesh problem attached.

Steps to recreate.

  1. Sweep 1 rail
  2. In left view, trim the right side
  3. Front trim in 2 steps (above and then between

I tried adjusting the mesh settings as well as rebuilding the edges and the original curves. I also tried to extrude with direction instead. Nothing improves.


TestSweep.3dm (33.9 KB)
edit: This is V5 SR12 FYI

The file you attached has 5 curves and 5 text dots. It does not have any surfaces. Can you post a file with the surface as shown in you illustration.

What are the symptons of your difficulties?
Why do you think it is render mesh problem?
What mesh settings are you using?

Hi David,

You can see the kink in the render mesh on the rounded portion of the surface. The textdots are just the steps to recreate the surface. The reason its render mesh problem is that is you Section the surface the curves created conform to the edges of the surface. I have attached the result.

Thanks for your help!!

TestSweep Result.3dm (76.5 KB)


i used the mesh settings below to prevent the error. Not sure what is causing this though.


Thanks Clement,

Custom mesh works but the simple sweep option doesn’t on my end. After the second trim the bad render mesh reappears. Anyway, I can move forward with custom mesh.

Thanks again,



yes, i`ve just removed that from my post above as i was mixing up sweep rail and profile. If i do it sweep according to the annotation dots the surface looks less dense. I guess the problem is related to the custom mesh settings used globally in your file. They are too coarse for the model size and setting to many of the fields to zero does not give the mesher a chance to do it right.

You might change the global mesh settings while _ShowRenderMesh is active for all important parts to optimize it. Then use _HideRenderMesh to get rid of the mesh display.


Wow nice trick. I new about ShowRenderMesh but had not thought to use combined with mesh setting. It was always back and forth between the option panel and highlighting the surface.

Do you regularly have to use custom mesh in your work? Honestly, since V5, the defaults have always worked for us and we always use mm on our ship designs that are 50 to 100m (i.e. always large models).


Yes, expecially when modeling eg. ship design exteriors where i have many piped handrails along with large sized hulls. I could not do it with one setting only.


Hi Etienne - try DivideAlongCreases > SplitAtTangents=Yes - that should clean it up. (but it will be a polysurface)



Another trick in the bag. I don’t mind polysurfaces in this case so this works