Render LED

Hi, I’m an industrial design student, and I´m rendering a pop up store, but I want to make the effect of a LED as shown in the image, I tried changing the material and putting spotlights but I don’t have the effect that I’m looking for, can someone help me?
Captura de pantalla (200)

build a tube (closed object) use an emissive material on your light source object, then choose the color.

run raytrace mode and crank up the emission strength until it looks right to you-

you can also run a stand alone render with the render command and then add a glow post effect for each color.

1 Like

I need some practice with this as well so I’ve used Kyle’s advice to produce the image below:

I’ve been struggling with lighting but I just need practice. My hardware might be a restricting factor as well, not sure. This render has turned out far better than some of the other things I’ve tried. I’m trying to add glow in the actual render and not post-process. I want my lights/emissions to look more like the example in Rhino’s material guide:


I guess to sum up what I’m trying to achieve with emissions: It feels like the emission isn’t casting light anywhere other than it’s own surface. I’m confused at the differences between lights and emissions. And if lights are kind of a redundant feature after R6.

1 Like

And while we’re here, I think I found a bug. I’m trying to add glow post process. It looks pretty good, but whenever I try to add additional colors, it just keeps adding new ‘glows’ almost as if the button is stuck:

1 Like

Hi @keithscadservices
That adding of the buttons is yet another bug that has not been fixed in Rhino V7.
Adding another Glow color keeps adding slots - Rhino / Rhino for Windows - McNeel Forum

Note that I’m far from an advanced Rhino user (especially when it comes to rendering). I’ve been playing around some more and may have found some useful tips. I also wouldn’t mind getting some feedback from developers on how to get emission materials to behave more like “lights”. The current solution I found works for a straight light but wouldn’t work for say, a path like a neon light.

I’m using linear lights for the “glow” effect and using physically-based emissions to help visualize where the lights actually are. Using emissions alone seems to not produce the same glow I can get with a light. But when using lights alone there is no way to preview their location. So using both allows me to have the “glow” (from the lights) and the emissions allow me to see where the LED actually exists. I’m using physically-based materials with emissions instead of simply using an emission because the physically-based material allows for both the emission and transparency to exist at the same time; I’m placing the linear lights within the emission objects and therefore, the material transparency gives me an additional control over the intensity of the lights.

I’m still battling a few issues. First being that I wish I could just use emissions via the materials instead of having to combine emissions with lights. Next, I’m wondering about the shadow in the back corner: Would it actually exist? The emissions are casting a shadow but aren’t they also glowing (and therefore would emit light in that direction?); perhaps I’ve overlooked a setting somewhere. Some of the issues I’m having might also be hardware related.

Here’s a screen shot of my settings. Note that I might have had the first light turned off during the render. it’s just a square light on the ceiling. You can also see how the lights look in “realistic” and “rendered” display modes. Overall, the “preview” modes look a lot different than the final render. Overall brightness is also way different. It’s actually really hard to render on a mediocre computer:

This is one of my botched renders for reference. It looked just fine in realistic mode. It looks like someone accidentally split an atom:

Too Bright

And… here’s a clip of the room just for reference:

Apologies if I’m hijacking this thread. I just happen to be attempting something similar to Maria at this time so hopefully it helps out in some way. I still need to work on getting more “glow” effect to look more like Maria’s first image.

pretty sure that in the reference image, we’re not seeing the lights directly, they are rather set behind tinted translucent plastic sheet (and I’d guess, are just plain white lights)

here is a model set up similarly for cycles:

plexi-backlit-cycles.3dm (173.1 KB)


Thanks jdhill! Definitely the solution to the original problem. I did my part at least by keeping the post towards the top of the forum :wink: . Using your project I changed mine a bit. I tried both colored emissions with white frosted glass and white emissions with colored frosted glass. Both producing similar results. The advantage to using either method depends on what you want to control. For example, using just the white emission material means you can control all of that material (and the intensity) all at once. This also solves the problem of having to mix lights with emissions. And those weird shadows didn’t show up in this render.

1 Like