Recommended method for more uniform lighting?

Often I find there is too many dark sides/spots on the 3D models I’m working on. Especially when looking at the bottom or behind a corner or whatever.

What’s the best way to get a more uniform lighting from all directions? I haven’t fiddled around with lighting settings too much, I don’t know the basics…

I’ve disabled cast/receive shadows in object properties already. But that doesn’t seem to change much

Using a solid white background and use that as skylight as well should give the most even lighting possible. This will work for both Rendered and Raytraced modes.

Hi Nathan,

Not sure how the background color affects the model itself? Or are you talking about the material color of the model? In that case, it’s already solid white.

But turning skylight on does improve visibility quite a bit.

Not in itself will it affect, but

this is the crucial part. If you’d use a basic environment with solid color (default is studio lighting) set to white you’d get the brightest, most even environmental lighting possible. You’d see how that skylight affects the appearance of your model if you dialed the color back to black…

edit: making a quick example file to illustrate…

edit2: skylight_example.3dm (3.3 MB)

Extreme example, but in the rendering panel switch the skylight custom environment between the black and white environments. From this follows also that an environment with an HDRi that has for instance lots of brownish colors (some interior say) the lighting will be brownish - an open sky HDRi texture would yield blueish… So the full white simple skylight environment will give even, full white lighting.

I’m using Rhino 5 by default. But I do have a trial version of Rhino 6 installed, so I was able to see your example.

So the white and black background react like ‘real life’ respectively reflecting and absorbing all the light and in this way affect the lighting of the 3D model?

Is this the same in Rhino 5? I didn’t have the same results with the model I’m currently working in.

Ah sorry, I didn’t realize you were on rhino5 still -I actualy don’t know much about rhino5 (or earlier), so I’ll have to let our @BrianJ s and @pascal s answer that.

I should have mentioned in my first post, my apologies


Are you asking about uniform lighting in the Rendered display mode, Shaded display mode or an actual Rendering using a Rendering plugin? Let me know and also post a 3dm as well as some screenshots in Rhino 5 to help explain what you see and I can help.

Hi Brian,

This is more of a general ‘complaint’ I have when working with Rhino. (Although I must admit I am new to 3D modelling, last time I did 3D modelling was maybe 10 years ago in solid edge)

But I feel like Rhino just displays things too dark alot of the time. It feels like light is only coming from one source, which makes some angles difficult to work in. The model I’m currently working with isn’t the best example. But I’ll try to demonstrate what I mean.

This side of the model is nicely visible

turn it around and the other side becomes much darker, harder to work with (again it’s really not the best example)

Maybe the solution is just to add an extra light somewhere? But I havent played around with the lighting controls yet. That’s actually the reason why I started this topic, because I was wondering there might be a more overall solution.

What display mode are you in? I think you are in Rendered mode which uses the lighting and environment settings in the file. See if Shaded mode is different for you, it ought to be by default much more evenly lit. Also check that the display mode you are using is set to the defaults in Options>View>Display Modes by running the Options command. If you post the 3dm file I can tell more.


Yes I’m using rendered mode. You’re also right about shaded mode, it does look much more evenly lighted, I rarely use shade mode though, it is not that useful for the kind of work I do.

I checked out the settings for the lighting in rendered mode. I’m not sure what to look for? I found ‘lighting method’ was set to ‘scene lighting’ instead of default. I flipped back and forth, there may be a small improvement, will need to test more.

Or maybe I’ll make a copy of the Shaded displaymode, and remove visibility for the meshlines and create a new ‘rendered’ displaymode with better lighting :slight_smile:

Yes, that’s what I was going to suggest in Rhino 5. The Shaded mode uses a custom material for the shading which adds a bit of an environment map to the surfaces making dark corners less likely to occur… it Rhino 4 this was problem at times so we updated the mode in v5. Moving onward and upward, Rhino 6 has new Rendered mode defaults and a mode called Arctic too that you might like as well.

Note that you can tweak the lighting setup for your copy of the Shaded display mode:

Make the lights lighter in color, maybe add some more.

I shall call it … Shendered mode!

Thanks for the help

1 Like

That is also very interesting. Might be what I was looking for in the first place.

Only I’m having a hard time visualizing what grey light looks like. Is this why the models appear grey in the viewports when the material color is actually set to white?

If so, why don’t we use white light and grey material by default? Sounds more ‘natural’ to me?

Note that the shaded mode wasn’t meant to look natural or correct, that is more for the Rendered mode. You probably could create a copy of Rendered where you specify a custom lighting scheme as in Shaded, just with the lights set to white… Second note: few lights in real world are actually white - most of them have a tint, yellowish or blueish(for the ‘white’ lights).