Read Only File/Temp file

You guys gotta fix the bug that causes Rhino to think it is a read only file. It generates a temp file while saving and then states that I cannot save because it is read only. This will happen with a unique file, that I have been working on and saving for hours, and then it will randomly decide it wont save, and it erases the file from the folder.

The only work around is to go to the folder, delete all the temp files, save as and rename the file something different. It’s not the end of the world, it just is really annoying when trying to maintain proper name/file management.

To give an update, it now happens every time I save.



Thanks for this report of what you’re seeing. Can you answer a few questions…

  • What version of Rhino including the service release are you running?
  • Are you saving to a network drive or a local one?
  • Are there any additional plugins you’re using in Rhino as well? These may be writing additional object info on each save and be part of the issue.

You can also disable the saving of .3dmbak files in Options>Rhino Options>Files to test if that is the part of the save operation that causes the issue on your end. Let me know the answers above too when you can. Thanks.

Hi Brian,

  1. I am using Version 6 SR13
    (6.13.19031.5531, 1/31/2019)

  2. Saving locally, but it is in a Dropbox Folder.

  3. I have 3 plugins installed, but have disabled them since I had an error with latency a while ago. They are Enscape, Octane and TableV2.

I disabled .3dmbak files, I will let you know if I continue to run into this issue.

Thank you.

Hello - I would test against an non-cloud-synced folder and see if that behaves differently.

1 Like

Thanks for the info, I agree with Pascal. I bet the DB folder is trying to sync to the cloud as well at the same time and that’s behind the issue. Each time you save, the 3dmbak is replaced with the version of the file you’re overwriting, essentially it becomes the last saved version. Let me know if saving to a non-cloud synced local folder fixes the issue on your end when 3dmbak is enabled please.