Bug: Rhino makes .3DMBAK files despite option being unchecked

unhandled

#1

Hi All,

I have just started running Rhino on a new laptop (Version 5 SR8 64-bit, 5.8.40305.11495, 03/05/2014). Despite having unchecked the option to create backup files they are still produced. This has never occurred to me on previous laptops and I was wondering if this is a known bug?

I should say that this is a laptop from work/university which grabs a license from a server, perhaps this could make a difference. However this was also the set-up on my laptop at my old job.

Thanks,

/Anders


#2

Same problem here. That box is unchecked but the file still wants to be created.

I am working on a file in my Google Drive and when I finished the session I got an error message saying the file could not be renamed *.3dmbak. I clicked OK and the session closed. I lost all work from that session of the model. I believe this is due to GoggleDrive not completing the sync upload of the *.3dmbak file before I exited. When working with large files the sync can take a long time even on fast dsl.

I would prefer to define where that file is created so I can stash it out of the GoogleDrive folder.


(Pascal Golay) #3

Hi All- I am not sure what is going on but the 3dmbak file, I believe, is created regardless as part of the Save process, and deleted if the setting is unchecked. @AndersDeleuran are 3dmbak files created and left in place, can you tell?

@JohnM, do you have an idea? So far as I can see here, 3dmbak files are following the Options setting.

-Pascal


#4

Pascal,
The problem for me occurred in the context of GoogleDrive which I use to keep current projects synched between my laptop and desktop. I am working with a 75MB model and save every 1/2 hour or so. In this instance I saved - got the error - and kept working. I was called away from my desk and quit the program 1/2 hour or so later and got the error again.
Since I had already clicked to close all I was presented with was a button for OK then Rhino was gone. The files that remained were over 1.5 hours old.
It would seem the save sequence is to first rename the .3dm file to.3dmbak - then save the .3dm file. If the rename can’t occur (due to locking in my case with gDrive in process of sync) no save occurs.
I would vote for no rename occurring if the checkbox for .3dmbak is cleared.


#5

Hi Pascal. I am running a few tests now and am not able to reproduce the problem! I’ll keep an eye out and report back if the 3dmbak files start reappearing. Thanks, Anders


(Marc Gibeault) #6

I now see this despite the option still unchecked, but it’s not every file.
Maybe it’s files on the network only?


#7

I have the same issue here. Working from a google drive folder on my desktop:

Followed by:


(Pascal Golay) #8

I’ve seen this as well with large files on Google Drive - my current theory is that Google drive is busy synching, possibly, because it often works a short time later.

-Pascal


#9

I think I’ve said this before, but this happens to me and all other users here when saving files directly to our university network drive. The first save of a new file works OK. After that I get:

Error replacing backup file “filepath_filename.3dmbak” with original file “filepath_filename.3dm” and original file “filepath_filename.3dm” with temp file "filepath\RHI6512.tmp"
Replace file function failed with error code 0.

That then leaves the .3dmbak file in place even though creating them is unchecked here as well.

–Mitch


#10

I still run into this problem on a daily base, is there a solution already?

Anyone experience with the new Drive File System from google? (is for G suite only)


#11

Yes… It’s called V6. :stuck_out_tongue_winking_eye:

It will not be fixed in V5, but appears to be working correctly (here at least) in the Beta.

–Mitch


#12

Can anyone confirm that this will be fixed for good in Rhino 6?
Almost daily I encounter this 3dmbak annoyance with Google drive…

thx, Tobias


#13

Do you save directly to a networked / cloud location?

I’ve always been told to save locally, like to my C: or D: drive … THEN LATER sync it to the cloud for back-up purposes.

I’m worried than any lag or interruption in my internet connection (never 100%!) will cause a very large file to get corrupted. The best case scenario is I only spend a lot of time waiting for save. Worst case is I lose the file.


#14

Hi Dave,
I don’t save directly to the cloud (actually I don’t even know if that is possible). I am saving to a local folder on my computer and this folder is monitored and automatically synced with a cloud folder by Google Drive.
While syncing a file it gets locked by GD…

gr, Tobias