RayTraced freeze Last WIP


#1

The Last Wip Raytraced Freeze.
Vittorio


(Nathan 'jesterKing' Letwory) #3

@vittorio, can you please elaborate on how it doesn’t work? What GPU are you using? Or is it CPU rendering?

On my machine the public WIP appears to be working just fine with Raytraced.

/Nathan


#4

Here, with even just a simple box, Raytraced is very laggy and not responsive. And in the time, while waiting for the view to react on mouse action, also the UI is not reacting. (GTX 770 and latest driver.)


(Nathan 'jesterKing' Letwory) #5

Hrm, that is weird.

@andy, do you know if there are still tricks to be done with the changequeue display pipeline to ensure message pumps are getting flushed properly?

edit: note that I cannot reproduce freezing, not on my GTX 1060 (non-display GPU), nor on my GTX 760 (GPU with two monitors attached). CPU rendering also goes fine. With latest public WIP 6.0.17052.4301.


#6

Hi Nathan
In the attached .txt file there are the about that you requeired
Ciao Vittorio

RhinoCyclesDevices.txt (8.71 KB)


(Nathan 'jesterKing' Letwory) #7

@vittorio,

Thanks for the information. It looks like it all should be OK. Could you please try resetting the Raytraced view settings to their defaults? I recently fixed a bug that always overwrote settings with defaults, potentially hiding some issues. Maybe it surfaces here now, too. So Tools > Options > View. Reset Raytraced, especially if Raytraced is in bold blue.

Let me know if it helps any.


#8

I tried it and it’s not possible to “unbold” Raytraced by clicking Restore Defaults for “Raytraced” or “Other Settings”. So, clicking it didn’t change anything and Raytraced view is still laggy.


#9

I Followed your instructions but no improvement.
Vittorio


(Andrea Montis) #10

Same problem here.


(Nathan 'jesterKing' Letwory) #11

I’ll be keeping my eyes open in case I’m able to reproduce.


#12

Maybe it’s not related, but this is what it looks like for ~1 second while starting latest WIP:


#13

@MarcusStrube,

i’ve got this too here when opening but i see no freezing so this may be unrelated. (but still something to fix).

c.


#14

Now Raytraced is completely gone. So, when I want to change the view to Raytraced this is all I get:


(Nathan 'jesterKing' Letwory) #15

Not sure what is going on here, that looks indeed completely broken.

Can you check out in the Options dialog under View > Display modes > Raytraced > Other Settings the realtime renderer assignment is set to Raytraced?


#16

Yes, I had (and have once more) restored defaults for Raytraced and Other Settings.


(Nathan 'jesterKing' Letwory) #17

As an extra test could you rename the settings folder while Rhino is NOT running, the start Rhino to see if that helps? The settings folder lives in %APPDATA%\McNeel\Rhinoceros\6.0

Note that you should rename it, so you can reinstate it if the test doesn’t help. Rename to something like xettings, or settingsold


#18

I did that and Raytraced is back.

Also the “laggyness” is better now. But still all the time the view is not updated properly. So, it stops after sample 3, 26 or 47 and then the view is updated when finished after 200 samples.


(Nathan 'jesterKing' Letwory) #19

Ok, good to hear Raytraced is back. That at least is something. We’ll be investigating the update issues more, though. I’ll let you know if and when we have something to test. I won’t promise I get anything conclusive before the next WIP (which hopefully ships on this Tuesday evening/night).


#20

I’ll just update and see what’s there…


(Brian Gillespie) #21

RH-37955 is fixed in the latest WIP