Freezes when I change out of Raytraced


#1

When I open any of my recent projects in WIP and set it to Raytraced and then try to set it to Shaded, the program freezes and I have to force quit. Currently I’m stuck on a ServerBusy splash screen.

These projects were created in V5 with either Thea or V-Ray materials. Not sure if that’s relevant.


(Nathan 'jesterKing' Letwory) #2

Can you please share a file with me for further investigation? You can use rhino3d.com/upload to send it to me. Enter nathan@mcneel.com in the recipient field, and please paste the link to this discussion in the comments field.

Thank you,

/Nathan


(Nathan 'jesterKing' Letwory) #4

hi, I received you file and tested switching to Raytraced, then back to Shaded without a problem.

With what device were you rendering?

/Nathan


#5

i7-6700
GTX 970
16gb ram

Not a monster machine but should be adequate to the task


(Nathan 'jesterKing' Letwory) #6

Could you test with the CPU to see if switching still causes freeze?


#7

same thing - Not Responding
And I notice the glass / plexi is not transparent when I set it to cpu. Not sure why that should change.


(Nathan 'jesterKing' Letwory) #8

Can you please paste the contents of _SystemInfo?


#9

Where do I get that?


(Nathan 'jesterKing' Letwory) #10

Type the command _SystemInfo.


#11

Uh, okay. But it’s a bit longer than War and Peace
And not sure why it’s called coffeesymbols

coffeesymbols_old.7z (5.4 KB)


(Nathan 'jesterKing' Letwory) #12

I am not sure where you git that from. The command should pop up a new window with the info I am looking for.
image


#13

Rhino 6 SR0 2017-7-25 (Rhino WIP, 6.0.17206.9241, Git hash:master @ 39c3b3a81deb1f40eda281891ff5319a64d207e9)

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

GeForce GTX 970/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 384.76)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: None
Anisotropic Filtering Mode: None

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 6-27-2017
Driver Version: 22.21.13.8476
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino WIP\Plug-ins\CyclesForRhino.rhp “Cycles for Rhino”
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”


(Nathan 'jesterKing' Letwory) #14

Your WIP is old, you should update. I think these freezes you experience have been handled.

Note though that the banding issue will be fixed only in the next public WIP.


#15

Unfortunately downloading the most current WIP did not solve the issue.
I’ll try again in a couple of weeks.


(Nathan 'jesterKing' Letwory) #16

Hmm, I have pretty much similar setup, rendering with either CPU or CUDA GPU, the switching to Shaded mode works just fine for me. Maybe ensure all the built-in display modes are all reset to their defaults?


#17

A couple of things -
This doesn’t seem to occur for projects started in WIP, only projects that originally started in V5 and then only projects that were either Thea or V-Ray projects. I’m not sure which because I regularly move between both renderers so some materials will be V-Ray, some Thea.

I once tried to download the ProRender plugin, unaware that it wasn’t being compiled anymore. Consequently I get this screen when I open WIP. I can’t find FireRender.rhp in my computer so I can’t kill it. When I open Details and select Never Load This Plugin Again it does nothing. I’m not sure if this might be a factor.

When WIP freezes I often get a Server is Busy screen which is given the WIP icon in Task Manager and needs to be killed separately:


(Nathan 'jesterKing' Letwory) #18

In the plug-in manager (Tools » Options » Plug-ins) you should be able to find the location ProRender is installed in. Remove it from there manually.

One thing to try still is renaming the settings folder under %APPDATA%\McNeel\Rhinoceros\6.0\ to something else, like settings_old before you start Rhino WIP.