Ending raytraced prematurely

Almost, or even EVERY time I try to cancle cycles (in viewport) prematurely by pressing escape or changing it to another display mode it freezes and I have to kill Rhino session.
I have noticed there are some new stuff in Cycles that adjust some settings but we haven’t been introduced properly to it (or have I missed something?)

What does that mean?

Viewport resolution sharpness: pixel perfect: pixel size is 1 meaning Cycles renders at the resolution requested… Moving it to the left the pixel size increases. One notch to the left from pixel perfect means pixel size 2. This means that effectively Cycles renders half of the resolution, which on turn means only 1/4th of the work to do. One notch more to the left means pixel size 3 - rendering at one third of the requested resolution. Again, much less to render for Cycles. This is for faster viewport rendering at the expense of resolution.

Viewport responsiveness: slower: render directly at the requested resolution (taking pixel size = resolution sharpness into account). Moving the slider to the left makes Cycles do progressive resolution refining. Completely to the left currently does a start resolution of 8, trying to render at 8x8 pixels. This gives a very pixelated resolution to start with. Each pass in this progressive refine phase will double the resolution count until the requested resolution has been achieved. This can give much faster response when manipulating the viewport or the model while Raytraced is active.


How can I explain it…
…you do some stuff in a eg. shaded view, then change it to raytraced to check the progress, then change it back to shaded to continue, but you can’t because Rhino froze…
whas it helpful?

I meant the press escape part… There is no escape to abort Raytraced…

I can’t reproduce this. I do this many times per day - switching back from raytraced to any other, even before raytraced actually started rendering. I just tested again with several of my bigger test files (700MB - 1,5GB) that take a while for Raytraced to get started. I tested both with different configurations of GPUs and CPU (1 thread, many threads). Unable to repro.

It wasn’t my intention to report it as a bug, more like FYI it can happen sometime for someone.

It happening sounds like a bug, but I’d need to be able to reproduce in order to fix it.

The only thing I can think of right now is that maybe you need to wait a while for Cycles to relinquish control in case you have a really slow machine at your disposal… If it just started rendering a pass switching away will take until that pass is done. If rendering one pass takes several or more seconds Rhino could feel stuck. But it should eventually switch to whatever mode you selected. It shouldn’t take too long though.

If you run again into this, and Rhino is really stuck (say a minute into waiting and still nothing) then please create a memory dump for me and please upload it to me using rhino3d.com/upload?to=nathan@mcneel.com

Please see Manually Creating a Memory Dump (DMP File) from an Unresponsive Rhino for Windows [McNeel Wiki] for instructions on how to create the memory dump.

Thanks in advance.

I have done the test by runnning raytraced view in a viewport.
It went as much as 11 passes then I tried to switch it to shaded view.
I gave it two minutes before I created dump file.
The dump is 4GB while the file itself is 40MB.
How can I transfer 4GB to you?

Please use rhino3d.com/upload?to=nathan@mcneel.com as I mentioned before.

It was more like a question: can it really be so big compared to the file size?
I’m uploading the file now, don’t know how long it is going to take, I’m doing it from private network in my parents house.
10 min and I’m still seeing this:

It is a memory dump, these can be large.

While we wait for the upload to complete, can you please post the results of the Rhino command _SystemInfo ?

Uploading 4GB failed, I will try to do it again when I’m back home.

System info attached:

Rhino 7 SR6 2021-5-4 (Rhino 7, 7.6.21124.09001, Git hash:master @ 1a9a92254a9f347268c4c9c7f2dec50bcd90215e)
License type: Commercial, build 2021-05-04
License details: Cloud Zoo

Windows 10.0.19041 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Unplugged [96% battery remaining] ~58 minutes left

Non-hybrid graphics configuration.
Primary display and OpenGL: Radeon Pro 560X (AMD) Memory: 4GB, Driver date: 9-10-2020 (M-D-Y). OpenGL Ver: 4.6.13596 Compatibility Profile Context FireGL 27.20.11036.1002

Integrated accelerated graphics device with 7 adapter port(s)

  • Windows Main Display is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 9-10-2020
Driver Version: 27.20.11036.1002
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\ClippingBox (4dfff1df-5f09-43ae-a044-77b115244b02)\\Rhino 6\ClippingBox.rhp “ClippingBox”
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\CreateQuadMesh (5bf6c0f3-3657-4ad5-834a-bbbb52706a40)\6.0.6914.24116\CreateQuadMesh.rhp “CreateQuadMesh” 6.0.6914.24116
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\Rhino 3DM File Version (aa091cb2-d8c0-4944-a17d-b66c80bec4ca)\7.0.7639.20582\RhinoFileVersion.rhp “Rhino 3DM File Version” 7.0.7639.20582
C:\Users\Piotr\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\AMDDenoiser\0.5.1\AMDDenoiser.Windows.rhp “AMDDenoiser.Windows”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.6.21124.9001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.6.21124.9001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.6.21124.9001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.6.21124.9001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.6.21124.9001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.6.21124.9001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\Calc.rhp “Calc”

Thanks, looks good to me.

Hopefully you’ll be able to upload later.

I have uploaded the dump file.
Just checked and I have to add that canceling the render window also cause Rhino to freeze and I have to kill the session.
I’m really looking forward to your findings.
PS It wasn’t like this before (ca. 2-3 weeks ago). WiP works fine.

The AMD denoisers seems to be involved here.

Does this problem happen when you disable all post-effects?

In any case I logged RH-64131 Rhino hanging while switching away from Raytraced with AMD denoiser active to track investigation on this.

My WiP doesn’t see denoiser (?) even though it’s there:

this could be a reason why WiP is not giving me troubles while switching between display styles BUT it freezes (too) when I try to cancel the render.

Hmm, there is a 0.5.1 version of the AMD denoiser plug-in.

Adding @DavidEranen into the thread so he can ask questions if he needs to find out more info.

Hi @Piotr,

There is now a new version of the AMD Denoiser on the package manager that should fix the freeze. Are you able to download it and test? The new denoiser version is 0.5.2.


1 Like

It seems like my WiP package manager doesn’t recognize it, V7 does and I updated it

I just run the test in V7, still freezing when trying to change the display mode.

Hi @Piotr,

Hmm. Here are some questions:

  1. When Raytraced is rendering, can you see if the AMDDenoiser is actually denoising the result?
  2. What is the size of the viewport that you are rendering?
  3. If the size is larger than ~50% of the screen, can you try to set the viewport size to somewhere around 512x512 and then try to reproduce the problem.
  4. When Rhino freezes, can you try to wait longer than 2 minutes? Try 5-10 minutes.
  5. When using the latest AMDDenoiser version (0.5.2) and Rhino freezes, can you make a dump again and send it to us? Rhino - Upload to Support