Raytrace speed down by 80% compared to Rhino 6

I just upgraded to 7 for the speed and render quality advertised but in retrace it’s taking about 2 minutes per cycle. It takes 1/2 hour to render a 800/600 draft quality render. Its impossible to preview presentations also because the lights read completely different in render mode than in raytrace.
This seems retroactive for an upgrade. Can this be addressed in the settings?

this is 4.5 mins in with 2/200 passes…

Screenshot 2021-03-11 at 15.39.31|690x367

also, opening a viewport that is in raytrace and clicking the mouse to switch to another mode makes rhino stop responding for about a minute and a half , or it crashes or you have to force quit.

Currently working on that

RH-61467 Raytraced mode on UHD monitors is no longer smoothly responsive