Raytrace takes 3hrs to export and image

Hi All,

Hope you are well working from home. I’ve run into a little bit of a laggy bind with the raytrace display mode on rhino 6 for Mac. I pause the rendering once it reaches 100 passes and then enter -Viewcapturetofile to which I enter the image dimensions of 4000 x 4000 pixels and leave the default 500 passes at the bottom. A progress bar appears on the left side panel and takes about 3 hrs to get to 100%. I had tried this earlier today and the image had resulted, to my dismay, in a white square. I am running this on a 2018 15.4" Macbook pro with Radeon Pro 555X 4 GB graphics card. I am also running photoshop CC, Dropbox, and Google Chrome while this is all happening. I’m not sure if this adds to the issue, but the majority of my CPU and memory is being eaten up by Rhino at this point (about 80%). If there is some troubleshooting I can do or modifications to make to my raytrace display mode settings I could do to speed this process up that would be fantastic.

I am rendering an interior of an apartment if this helps clarify anything, there are no light fixtures or emitters in the model, although one side is full glazing so all the light is coming from there. I hope I’m the only one have this issue, but if I’m not does anyone have any suggestions? Thanks, y’all!

  • Alexis

Hello,

A bit hard to say why it takes 3 hours, but say you render in the viewport at 800x800 then going for a 4000x4000 means 25 times the amount of pixels to calculate, and going from 100 passes to 500 is a further 5 times longer computation time. So if your 100 pass 800x800 takes 1 minute, then 500 passes of 800x800 takes 5 minutes. At 4000x4000 that means 125 minutes.

To optimize your scene for speed you can:

  • Hide any geometry you can’t see from the viewpoint you are rendering. For instance glass- and silverware in closed drawers and cupboards made out of solid material.
  • As few glassy materials as possible
  • As few highly reflective materials
  • Optimize geometry, tweak custom render mesh settings such that for each object it all still looks good, but has fewest possiible polygons
  • Use block instancing where possible
  • Use as few and as small textures as possible where visual quality is still according your standards