Raytrace Renders Black

rendering

(Nico van Loggerenberg) #1

Hi all

Have a very strange error - roughly every second render I make in V6 using raytraced mode comes out black (in PNG) or white (in JPG) - there is no other information.

Without changing any parameters or materials, if I render again, it renders correctly. Attached 2 render from the exact same file, done right after each other, not interrupted.

.


(jesterKing) #3

Can you please the results of the Rhino command _SystemInfo?


(Nico van Loggerenberg) #4

Sure:

Rhino 6 SR7 2018-7-29 (Rhino 6, 6.7.18210.11281, Git hash:master @ f815aae129dfe2008152736625ca2dbd0036b29a)
Licence type: Educational, build 2018-07-29
License details: Cloud Zoo. In use by: Nico Jabu Van Loggerenberg ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: NICO-ACER-V17

GeForce GTX 1060/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 398.36)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-24-2018
Driver Version: 24.21.13.9836
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.7.18210.11281
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.7.18210.11281
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.7.18210.11281
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.7.18210.11281
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”


(jesterKing) #5

Nothing that right now stands out why this would happen. If you have more information about when it happens I’d like to hear about it.

I’ll investigate this further when I’m back at the office in two weeks.


(Pcalifano) #6

I had a similar issue: when I tried to change the pixel scale value in Capture > to File, the render was black.
With the new update this problem seems gone. (to me)

Anyway, please, can I ask a simpler and cleaner render management system?
I’m new with Rhino, is there something that I’m missing?

For example I would like to set and see a panel that shows what I’ll see in the final render! Because actually I’m not able to do it, or just I don’t know how.
For example a vertical rectangular panel.

Hope this helps!
Cheers


(Nico van Loggerenberg) #7

Updated to the newest version, and the error is definitely still there. Intermittent.


(Pcalifano) #8

Really weird, I confirm that I’ve not this problem anymore. Just used the file that I had problem with. The new update seems to work for me. Did you try to render a super basic composition or another model? Maybe there’s a problem with your file…


(Nico van Loggerenberg) #9

Tried a brand new file, same issues.


(Pcalifano) #10

Mmh, I don’t know how I can help you, I’m sorry. As last advice, before I had this problem gone, I remember that I had nearly no more space on my disk, so I uninstalled some software and other stuff. Could it be something related to disk free space?
Really sorry I can’t help you more than this


(jesterKing) #11

Raytraced doesn’t use diskspace unless you have an OpenCL device selected as render device. Indirectly the used RDK will write textures to the texture cache on disk, though.


(Nico van Loggerenberg) #12

Definitely not disk space. Also considered that it might be an issue with cloud services, as all my files are directly on Dropbox etc, as it writes sequentially to the file, but writing to the desktop gives similar issues on occasion.


(Nathan 'jesterKing' Letwory) #13

In my tests Raytraced itself works fine. It is the moment when the results are put into the clipboard or saved to file by Rhino code that it fails.

You can run TestSaveDebugImagesToggle (or check similarly named setting in Tools > Options > Advanced, type SaveDebug in search filter field), then start a capture.

You should find under %APPDATA%\..\Local\McNeel\Rhinoceros\V6 or %TEMP%\McNeel\Rhino\V6 a file called RC_modal_renderer.png once the capture has completed. It’ll the uncorrected render result, so if you had gamma 2.2, you’ll need to adjust so in your favourite image editor. (In GIMP change the color levels)

edit: yes I know this is a hack and workaround, but at least you should be able to get your renders out while the bug is being on the table to be fixed.


(Nathan 'jesterKing' Letwory) #15

Actually, the path I mentioned is for either 6SR9 or 6SR10 onwards (forgot into which it got, probably the latter one).

Pre that it is %TEMP%\RC_modal_renderer.


(Nico van Loggerenberg) #16

Checked this with the newest update and it still persists.


#17

Does this only happen when you capture the image to file or clipboard?
If so, I suppose this one is on the list as RH-45147.


(Nico van Loggerenberg) #18

I never really use image to clipboard, so not sure. It happens with ViewCapturetoFile


(Nathan 'jesterKing' Letwory) #19

There is not much difference between _ViewCaptureToFile and _ViewCaptureToClipboard. The exact same code path is followed up until either putting the image in clipboard or saving to file. It is the step prior to this that the managing of the render result fails, it is somewhere in Rhino core code, and https://mcneel.myjetbrains.com/youtrack/issue/RH-45147 is indeed the YT item for this, assigned to @andy.

With either capture command using the steps outlined above you should be able to find the RC_modal_renderer.png as mentioned. Or otherwise use the rhino-render-next test package through the beta package manager that can be started with _TestPackageManager.