ProRender Locking up on start ( or not start I guess)

Hey All,

Well, of course just before a project is due you run into problems, right?! So I am trying to render a very simple file, I’ve actually even tried this on other files, where I just had a block or cylinder displayed, and I am having the same issue with Rhino 6 ProRender. When I change display mode to any choice besides ProRender I have no problem. Even when using Raytraced (cycles) my computer hums along and generates an image. But, if I switch to ProRender, I get the note at the bottom of the viewport “ProRender Rendering…”. I can hear my computer working hard but the screen is not changing to a ProRendered image. If I try to change the display mode to something else now, like “Artic” nothing happens. The computer continues to strain away. If I click anywhere in the UI I get the message at the top of Rhino saying “Not Responding”. Then I need to force close the app.

In actually rendering images, I find the same thing happening. if I set the current renderer to Rhino Render, I’m able to get a scene to render out as usual. All controls like Resolution, View etc all work. But, If I select ProRender as the current renderer and click on “render” the render screen comes up and at the bottom I see the message “Rendering Frame 0/128 0%” and the render never starts.

I’ve tried reinstalling the program, changing settings for Cycles like: device settings from CPU to CUDA, and changed throttling from 20 to 50ms and samples from 500 down to 200, but no change. ProRender still locks up.

Below is my system info. Has anyone else had this issue? Thanks:

Rhino 6 SR8 2018-8-28 (Rhino 6, 6.8.18240.20051, Git hash:master @ d037927543424e8b3ce54e46b435866178a6349c)
Licence type: Commercial, build 2018-08-28
License details: Cloud Zoo. In use by: j.w. ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: XXXXXXXXX

GeForce GPU/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 399.07)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 8-21-2018
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.8.18240.20051
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\ProRender (2aae3eb3-985b-4e64-b19a-fed69ef9dfeb)\2017.11.6.756\ProRender.rhp “ProRender”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.8.18240.20051
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.8.18240.20051
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.8.18240.20051
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

The Cycles settings are for the Cycles engine, used by Raytraced. ProRender is completely separate to that.

You could at least try updating to the newer version here

ProRender is an OpenCL-based renderer, specifically designed for AMD GPUs. It works on other platforms, but won’t be as fast.

I’d stick with Raytraced and _ViewCaptureToFile and _ViewCaptureToClipboard to pull out renderings.


p.s. if you’re up for some unfinished (but working) mechanism see this post for getting production renders out.

Hi @nathanletwory, i’ve closed RH6, downloaded, unblocked the rhi, installed using the “just me” option. After i’ve opened RH6 i got this:

Has the plugin been tested with RH6 ?

The plug-in loads in my 6SR8.

Sounds like there is some left over cruft in the registry that interferes.

Perhaps remove all ProRender folders from %APPDATA%\McNeel\Rhinoceros\6.0 after taking note of the GUID in the folder name. Then search for the GUID in your registry and remove the folder entries for ProRender.

Then re-install and see if that works better.

Thanks @nathanletwory,
i’ve found out it does not load because it installs in “2018.1.18.804\ProRender” under this folder:

%AppData%\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\ProRender (2aae3eb3-985b-4e64-b19a-fed69ef9dfeb)

After removing the old plugin folder “2017.11.6” and once i copied the files from the ProRender folder into the folder “2018.1.18.804” i’ve opened RH6 and installed it manually from the plugin manager.

It loads, and starts to render too, but it does not render any objects, they just blink once but only the backround is rendered.


There is already a YT item open with the dev who did the integration.

Ok thanks, i can wait until this is resolved then.