Rhino 6 Raytrace crash

raytraced
unhandled

(Gevoaelian) #1

Hello Everyone!

So I am using Rhino 6 and the raytrace mode keeps on crashing every time I go from another view to that. Example if i am on shaded mode and i want to change it to raytrace it crashes. I am not doing anything fancy I basically just create a solid box then I change the view to ray trace and rhino crashes. I have the most up to date rhino 6.

I have version

Rhino 6 SR3 2018-3-31

Any ideas on how i can fix this issue.


#2

To be able to help we need to know some system information.
Please type “SystemInfo” and copy-paste the data here.


(Nathan 'jesterKing' Letwory) #3

That is the _SystemInfo command in Rhino, not the SystemInfo command in the Windows powershell.


(Gevoaelian) #4

Hey Guys!

here is the info from the systeminfo command from rhino. I really hope you guys can figure out what the issue is.

Cheers!

GeForce GT 750M/PCIe/SSE2 (OpenGL ver:4.4.0)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.4
Shading Language: 4.40 NVIDIA via Cg compiler
Driver Date: NA
Driver Version: NA
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”


(Nathan 'jesterKing' Letwory) #5

You probably should update your Nvidia driver - I think this driver should be ok: http://www.nvidia.co.uk/download/driverResults.aspx/132997/en-uk

If possible try to do a clean driver install, i.e. ensure older drivers are uninstalled.

Let us know if this helped or not.

/Nathan

P.s. it is a good idea to paste the entire sysinfo result next time.


(Gevoaelian) #6

It says that it is not compatible with this version of Windows. What should i do? Any ideas?


#7

https://www.geforce.co.uk/drivers
You can search from here.
GT750m so notebook version.

And just need to select your os 32bit?64bit?
Win 10? Win7?


(Gevoaelian) #8

would you happen to know which one would it be? There was a variety versions


(Declan Halpin) #9

I’m having the same issue. I downloaded the correct driver (GT 540M, Win7 64 bit), and the laptop wouldn’t even boot. Luckily I created a system restore point - I suggest you do the same.

Windows device manager says my driver is up to date, despite being from 2013. Rhino (v5 and v6) would ignore this driver and use the integrated card. I rolled back to the previous driver and Rhino uses the Nvidia card, however I get the raytrace crash that Gevoaelian describes. Also, geometry is invisible when created, until I toggle display modes (wireframe to shaded, etc).


#10

It’s probably a package that works for listed OS.

Can you find which OS you have?

You should be able to do manual search from as attached


#11

Ok, now I need to know what kind of machine it is,
what version of Windows are you running and
is this a dual display card machine?

Cheers


(Declan Halpin) #12

Sorry, Gevoaelian, I’m not trying to hijack your post, just hoping my info might shed light on the issue.

I’m using a Dell XPS 15, win7 64-bit. It has the integrated graphics and a GT 540M.

On the Nvidia site I did select the correct system options, but all of the drivers offered either wont boot, or boot with a black screen. I’ve tried the newest, the oldest, and something in the middle. I manually uninstall/delete prior drivers before installing. I’ve just deleted the Nvidia driver again and allowed Windows to auto detect the card. It is showing up in the device manager as “working properly” and I’ve set the global and application settings to use it. Even right-click the Rhino icon and specify Graphics card.

So, to summarize: Rhino won’t use the Nvidia card unless I roll back to a driver from 2012 (via device manager). Even then Raytracing will crash. All attempts to install newer drivers via Nvidia site will not boot or boot with black screen.

And here is my own thread, if the admins would like to keep these two issues separate:

Thanks!


#13

Yeah… it seems DELL’s latest nVidia driver on the L502X is from 2012…

And you have to check with @nathan if Raytraced is even supported fully on Windows7 on those old cards.

BUT, you don’t want to use the GPU for Raytraced anyhow, because the 540 has only 96 CUDA cores. So switch to CPU and you should be good to go.

image


(Gevoaelian) #14

Thanks everyone! The Ray trace worked for me now. Once I installed the driver it worked and did not crash. The only thing is that it takes forever to manuover in that view.


#15

(Did you try with CPU instead?)

Any way, you have to toggle this:

@nathanletwory this should be ON by default and we need an option for it on the Cycles panel too.
Now it is way to hidden. Having UseStartResolution = OFF isn’t even an option for me on the GTX1070, so it makes no sense to not have it ON. Please fix so we don’t have to inform every user :wink:


(Nathan 'jesterKing' Letwory) #16

psst, it is @nathanletwory:slight_smile:


#17

Oh… thanks