Quadro drivers updated - Good news

I see, thank you for the clarification.

We have been seeing the dynamic streaming mode help with stability in the past. I am not clear with this new driver if the stability is helped with dynamic streaming or not. We have not had enough time with the new driver yet.

The dynamic mode does the job like in the past. It doesn’t solve the problem of the slow FPS, but doesn’t bring new problems.

I’ve only got a lowly 2000D… should I update?

If the supported model section on the driver description lists your card as supported then I’d say yes.
That said, I’d be sure to make a manual Windows System Restore Point in the event there is a problem.

If you search using this page, the 340.66 driver update does support the 2000D card: http://www.nvidia.com/Download/index.aspx

Hi @Micha, In the new 340.66 Quadro Driver I noticed that there is a new Option at the bottom of the list.
There is the old Workstation App - Dynamic Streaming, but there is a new option called Workstation App - Advanced Streaming.
I am getting similar performance times as I did on the 3D App - Default Global Settings, and no noticeable delays on my Quadro6000. Perhaps try this new Nvidia Control Panel option.
I set mine to Advanced Streaming and then Set the Power Management to Prefer Maximum Performance again.
It seems to reset this back to Nvidia Controlled each time you change the option.
Edit: I’ve also noticed that Max Performance mode causes the GPU to run at top clock speed of 574Mhz (And top temperature) as long as Rhino3D is open. As soon as I close Rhino3D then the GPU gradually downclocks itself to 51Mhz in normal Windows Aero mode to save power and heat. Not a problem, but interesting that if you leave Rhino running(even minimised) the GPU does not downclock. Under Nvidia Controlled settings the clock speed would jump around between the 4 x power speeds contantly even with Rhino open.

Yes!
This works great here as well! It seems all the old Quadro issues are gone (so far).
(Edit: My only issues were either speed or microlagging. The card was always stable.)

I’ll use these settings now and I’ll keep you posted. (Quadro 4000, win 7)

@scottd, @jeff
Did you guys see this new setting?

I hope this is a real solution. I know the emphasis has always been to make Rhino work on the most cards as possible, but the desire for inclusion seems to have made Rhino not work fantastically on any card; and I feel it is important for you guys to know that, at least in my field, it is starting to cause a migration away from Rhino to other packages. People have grown frustrated with the disparity in display speeds between Rhino and other software. Trying to show a supervisor or a client a slow tumbling model is much less than ideal, or trying to use and navigate layouts with multiple details proves almost unusable if you don’t hide everything or turn details to wireframe. That is not acceptable for us in a professional setting, and I hope it is unacceptable for you was well.

I would like urge McNeel to not underestimate the needs of their professional users. If you continue to only cater to the casual or educational user, you will lose those who need exceptional performance from their software. If you need to employ more tricks to improve speed, then do it. If you need to charge us more for it, then do it, but please make it available to those who want and need it.

2 Likes

Hello @John_Brock @jeff @scottd, I found this PDF from Nvidia online with some vague but interesting info regarding these Quadro options. It is from 2012 so perhaps there is a newer version of this document.
Page 38 is most interesting regarding preset Quadro Modes.
http://on-demand.gputechconf.com/gtc/2012/presentations/S0341-Monday-See-Big-Picture-Scalable.pdf

@scottd and @brian, would it be possible to invite the NVIDIA guys to this discussion? It seems like they would be able to give some more direct input.

I also thinks it’s time we start asking for our own Profile to be included with their drivers. This was mentioned a couple months ago by them, and it looks like we’re zeroing in on what that profile would look like.

I invited Digvijay to weigh in on this conversation using the Invite button below. I’ll also email him, as there wasn’t a way for me to put any personal comments in the invitation.

This thread suddenly went very quiet. Has the new setting solved everyone’s quadro problems?

We are waiting to see if anyone continues to have trouble with the new drivers and settings. At this time it seems to be a substantial improvement. We continue to update the wiki page based on the current information on the this thread. http://wiki.mcneel.com/rhino/nvidiainfo.

After a few days using the 340.66 driver, my experience is varied. The initial increase in performance was terrific, but after working for a while the graphics seemed to slow down again. So I checked the sphere test and the max speed test changed from 0.8s to 2.8s.

The setting used was ‘Workstation App - Dynamic Streaming’ with power management set to maximum performance.

The speed improved again after a clean reinstall of the driver, then slowed again after a while.
Sometimes a Rhino reboot fixed it other times not. At one stage I had 2 instances of Rhino open on different screens, both with the sphere test and one had the 0.8s result and the other the 2.8s result.

No other programes were running at the time so in my case it seems a Rhino operation is triggering the slowdown, or something behind the scenes on my computer, anyone else seeing this slowdown?

I changed the setting to ‘3D App - Default Global Settings’, with power management set to max performance, after reading @Holo Jorgen’s report and the sphere test is now .9s and stable so far so I’ll keep this setting for a bit and try the sphere test periodically.
Edit. I experienced the slowdown again, although a Rhino reboot fixes it.

I am now trying ‘Workstation App - Advanced Streaming’ set to max performance and the speed is good and stable so far. ( I’m randomly checking the 100 sphere test)

Brian, are you using a laptop or desktop? Do you “Hybernate” the computer or completely shut it down? Does it ever “go to sleep” and have to be woken up?

Thanks,
-Jeff

Dell T5600 desktop and I shut down each night and if I’m away for a couple of hours. Hybernate is set to 30 minutes and I’ll use the hybernate if I’m going out for a short while, so yes, hybernate kicks in once a day anyway.

Ok, I would be curious if you see things start slowing down after hibernating, or if it’s more random.

So if possible, keep a closer eye on that situation.

Thanks,
-J

Hi Jeff

I’ve put the computer to sleep under both settings, Dynamic and Advanced streaming and the speed results were fine - I’ll keep an eye on things and try and pinpoint the trigger.