GPU Nvidia Quadro M2000m

Hi all!

With Windows 11 (not updated to the latest version, because it disables all my .exe programs) and an Nvidia Quadro M2000m, I’m having problems making the GPU work with Rhino7. I’ve already changed the graphic settings from Windows, ensuring that Rhino would use the selected GPU, and already checked the Nvidia control panel and specified there for Rhino to use the same GPU (I can see the GPU activating for Rhino in its display), etc., but still, for “simple” operations like changing the viewport, Rhino makes its calculations with the CPU, using obviously the 100% of it and then crashing/not responding. For a brief moment yesterday (idk what I did), I managed to fix that (but evidently it wasn’t a lasting fix), and I saw how well/fast it worked if it just made its calculations with the GPU. Anyone with the same problem? What could I do? I already uninstalled/reinstalled everything a few times, and I’m out of resources.

Thank you very much!

  1. Please provide the outputs of the Rhino command _SystemInfo
  2. Does the crashing happen with specific files only? Or does it happen with say just a _Box in a new file?
  3. Share a file with which the crashing happens, please
  4. Not all operations are done on the GPU. Switching between display modes still can use CPU a lot, for instance when objects need to be meshed, or preparing data when going to Raytraced. It’d be great if you could be more specific in your description of when these problems happen.

Thank you for the replay!

Here the _SystemInfo output:

Rhino 7 SR24 2022-11-4 (Rhino 7, 7.24.22308.15001, Git hash:master @ cb2ad12922ceb989b185972675bb705a00abb97d)
License type: Valutazione, build 2022-11-04
License details: Cloud Zoo
Expires on: 2023-02-14

Windows 11 (10.0.22000 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [14% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) HD Graphics P530 (Intel) Memory: 1GB, Driver date: 2-3-2022 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA Quadro M2000M (NVidia) Memory: 4GB, Driver date: 11-2-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 526.67
> Integrated accelerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-2-2022
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Datasmith Rhino Exporter (d1fdc795-b334-4933-b680-088119cdc6bb)\DatasmithRhino7.rhp “Datasmith Exporter”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.24.22308.15001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

The crash happens with all the files I’ve been working on, and they’re around 200++ MB (not small). In a file with just a box in it, the viewport change works ok. The fact is, for a small moment yesterday (I thought I fixed it but when I started working again some hours later the “magic” was gone), the viewport changes to pen or raytraced were super quick/smooth, for it was actually using the GPU instead of the CPU (and that was happening on a file that’s the original of the one I’m attaching - 2 times bigger than this one. Still, the same problem occurs with this one too). If those kinds of operations are not done on the GPU, I honestly can’t explain why yesterday it really seemed like they did. I’m uploading also a screen of the task manager while Rhino tries to change to “pen” in the attached file (it’s been frozen for a while now, 10 minutes - had to force it to close).

SCREEN image
FILE WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

Thank you again!

It happens to me as well, I have a GPU Nvidia Quadro M500m with Windows 10. It would be awesome to find a solution! Thanks to anyone that helps!

Have you tried setting the OpenGL Level down to 3.3? It might help.

I just tried, same thing… thank you though!

Did you say you’re using raytracing? Your GPU dates to 2015, before GPU raytracing was really a thing. It doesn’t have a ton of VRAM, and probably is just struggling with large files and multiple viewports

Do you think so? Then why yesterday it worked really well for a while?

Who knows, but Rhino from version 6 on really needs a reasonably modern computer, and it needs Windows and everything up-to-date.

I have an old spare machine running a 4th gen i7 3.4ghz from 2013 with 32gig ram and had a geforce card from back then but updated it to a quadro rtx 4000 a few years ago and runs smooth as butter, however I’m running win 10 on it. I’m pretty sure if you replace the gpu it will run quite well. what cpu do you have?

1 Like

Have you tried downgrading you GPU drivers. I experienced degraded performance on 526.xx.

Since the M2000M is a GPU based on the Maxwell architecture it should still be capable of rendering for Raytraced, even though it is already 7 years old (which is old in the industry).

Double-check Tools > Options > Cycles to see if your GPU is selected as the rendering device.

The screenshot you shared most likely doesn’t show CUDA usage by default, but rather the 3D usage. For Raytraced you may want to ensure the GPU resource is set to show compute or CUDA to see the actual GPU utilization during Raytraced.

If you have lots of objects with mesh modifiers as displacement, shutlining or thickness that can add to the setup time for at least Raytraced.

Pen and technical can take time because the geometry needs to be preprocessed to find the outlines and hidden lines.

Both mesh modifiers and the setup for pen, technical, artistic are done on the CPU, before the actual drawing is handed of the GPU.

The kitchen model you shared is nice looking. I didn’t see anything out of the ordinary that.

Note that on your GPU you have only 4GB RAM, which is not much for larger scenes. Especially if you have lots of large textures. In this particular scene you don’t appear to have that many so that shouldn’t be a problem.

1 Like