Python Editor crash


#1

Expanding the tree inside the Method Browser is causing a rhino crash.

Work In Progress
(6.0.17116.6371, 26/04/2017)
Windows 10


(Dale Fugier) #4

Hi Bogdan,

Sorry but we’ve been unable to reproduce the crash you’ve reported. Can you repeat this? If so, can we get step-by-step instructions?

– Dale


#5

Hi Dale,

I can replicate this. I just start Rhino, run EditPythonScript, than expand rhinoscriptsyntax and than, for example, application. I will see a Loading text and than i get the Rhino WIP has stopped working error.
I thought it might be a conflict between Rhino5 and 6 if they are both open but I tested and it seems not to be the case.
The problem persists even if i restart the computer.

What else do you suggest I should test?


(Pascal Golay) #6

I’ve tried to make this happen as well, and I cannot… seems fine here. @dale - is it a video thing, do you think?

-Pascal


(Steve Baer) #7

Do you have to have a specific script open when you do this or does it happen all of the time?


#8

I also checked on another computer and it works fine.

The crash is happening on an Asus n552v, which has a GeForce GTX 960M.
This happens all the time without me opening any file or script.


(Steve Baer) #9

Did you ever install IronPython on this computer?


#10

No, I haven’t.


#11

This problem still persists.
I tested by running Rhino on intel integrated card and on nvida card. So it seems that it might not be a display issue?


(Dale Fugier) #12

Hi Bogdan,

When the crash occurs, are you presented with a dialog that asks you if you want to submit your crash information? does Rhino leave a ‘crash’ or ‘dump’ file on your desktop?

– Dale


#13

No, I get only the Windows dialog “Rhino WIP has stopped working”.


#14

Hi, I’m not sure if this is the same issue, but I am unable to open the Python Editor. When I select

Command: _EditPythonScript

I receive the message:

Error occured loading plug-in
 Details:
Failed to load language 'IronPython 2.7.5': Method not found: 'Boolean Microsoft.Scripting.Utils.ReflectionUtils.IsInterface(System.Type)'.Unknown command: _EditPythonScript

Version: Rhino 6 SR0 2017-6-6 (Rhino WIP, 6.0.17157.8191


Cannot run _EditPythonScript . "Failed to load language..."
#15

Welp, Steve solved my problem. I had an additional install of IronPython to my computer. Uninstalling that solved the issue


#16

Yes, I solved this by uninstalling IronPython with Add/Remove programs. :smiley: