Proxy for zoo server not working


#1

We’re a school (1500+ students) that are migrating to use Rhino 5 in our computer labs. We have software that restricts what students can do on the machines, and part of those restrictions is to deny internet access to student machines. The way this is done (3rd party product) is to change the proxy in the registry to a non existent server.

Of course this then fouls up the Zoo server as the student machines can no longer access it to get license authority. We were hoping that the zoo server used it’s own tcpip port but as 80 was chosen everything goes through http processing. In internet explorer we can enter the proxy and exception for our zoo server and then it works. Unfortunately this isn’t an option as IE is a restricted program on student machines.

We’ve written a program to modify the registry Settings directly (ProxyOverride, DefaultConnectionSettings, etc) and after that we do have access to the zoo server machine through both Firefox and IE, but Rhino still fails. In fact, I can see from an Analysis with Process Monitor that Rhino doesn’t even attempt to do a TCPIP_connect to the zoo server (I do see it with no proxy enabled).

What else do we need to set up to get the connection to proceed?

Thx


(Dale Fugier) #2

I would think just running Netsh WinHTTP set proxy proxy-server=<server> would be sufficient. But perhaps Netsh has some Windows version dependencies.

Rather than using a bogus proxy server address, have you thought about installing a real proxy server? There are several available for Windows, and at least one of them is free. You could then forward all but Rhino traffic some something that would display the error of your choice.

– Dale


#3

We’ve tried a real proxy server, but that didn’t work either. The problem remains that unless you run ie the settings aren’t applied. The can be displayed, but something prevents them from becoming active. This is a known problem (solutions exist, but they involve starting ie under the covers).

The same problem exists with netsh WinHTTP. You can set the proxy server and exclude local addresses, but Rhino still doesn’t find the zoo server. What was more concerning to me was that Rhino wasn’t even trying to connect to it.


(Dale Fugier) #4

You might consider downloading the Zoo diagnostic utility to see if it can provide any insight.

– Dale