Program crashing whenever I try to render

Can anybody find what the problem is? It’s a project for school and I need to solve this asap. Rendering worked - slowly - and suddenly stopped, I made no changes to the file before it stopped working. Could it be an issue with the latest Mac OS Update? It’s the only factor I could link to the malfunction. Thanks for the help!

Hi @chiaranottola,

Can you please paste Rhino’s System Information text here? Help -> System Information....

What are the steps you take to reproduce the crash?

I will test the file you included.

-David

Thank you! I position the camera, then either click on render from the icon or from the menu to the right and it crashes. Here’s the System information:

Rhino 7 SR7 2021-5-31 (Rhino 7, 7.7.21151.13002, Git hash:master @ 24d76fc798fa6ffd33733e5f18b034d547b87840)
License type: Educational, build 2021-05-31
License details: Cloud Zoo

Apple Intel 64-bit macOS Version 11.4 (Build 20F71) (Physical RAM: 16Gb)
Mac Model Identifier: MacBookPro17,1
Language: en-US (MacOS default)

Apple M1 (OpenGL ver:4.1 Metal - 71.6.4)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Apple
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 10922 MB
Graphics: Apple M1
Displays: Unknown (255dpi 2x)

Graphics processors
Apple M1
Color LCD (1440 x 900 @ 60.00Hz)

USB devices
None

Bluetooth devices
None

Third party kernel extensions
None

Third party plugins
/Library/Apple/usr/libexec/oah/runtime
/usr/lib/swift/libswiftCore.dylib
/usr/lib/swift/libswiftCoreFoundation.dylib
/usr/lib/swift/libswiftCoreGraphics.dylib
/usr/lib/swift/libswiftDarwin.dylib
/usr/lib/swift/libswiftDispatch.dylib
/usr/lib/swift/libswiftFoundation.dylib
/usr/lib/swift/libswiftIOKit.dylib
/usr/lib/swift/libswiftOSLog.dylib
/usr/lib/swift/libswiftObjectiveC.dylib
/usr/lib/swift/libswiftXPC.dylib
/usr/lib/swift/libswiftos.dylib
/usr/lib/swift/libswiftAppKit.dylib
/usr/lib/swift/libswiftCloudKit.dylib
/usr/lib/swift/libswiftContacts.dylib
/usr/lib/swift/libswiftCoreData.dylib
/usr/lib/swift/libswiftCoreImage.dylib
/usr/lib/swift/libswiftCoreLocation.dylib
/usr/lib/swift/libswiftMetal.dylib
/usr/lib/swift/libswiftQuartzCore.dylib
/usr/lib/swift/libswiftUniformTypeIdentifiers.dylib
/usr/lib/swift/libswiftsimd.dylib
/usr/lib/swift/libswiftAccelerate.dylib
/usr/lib/log/liblog_network.dylib

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
/Applications/Rhino 7.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 7.7.21151.1002
/Applications/Rhino 7.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 7.7.21151.1002
/Applications/Rhino 7.app/Contents/PlugIns/AnimationTools.rhp “AnimationTools” 7.7.21151.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 7.7.21151.1002
/Applications/Rhino 7.app/Contents/PlugIns/Displacement.rhp “Displacement” 7.7.21151.1002
/Applications/Rhino 7.app/Contents/PlugIns/RhinoRender.rhp “Legacy Rhino Render” 7.7.21151.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 7.7.21151.13002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Import_OBJ.rhp “Import_OBJ” 7.7.21151.13002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_XAML.rhp “export_xaml” 7.7.21151.13002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/QuadRemesh.rhp “QuadRemesh” 7.7.21151.13002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_OBJ.rhp “export_OBJ” 7.7.21151.13002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 7.7.21151.13002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_SVG.rhp “Export SVG” 7.7.21151.13002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/MeshCommands.rhp “MeshCommands” 7.7.21151.13002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_DAE.rhp “Export_DAE” 7.7.21151.13002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_PDF.rhp “PDF Export” 7.7.21151.13002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_IGES.rhp “IGES Export Plug-in” 7.7.21151.13002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Import_SVG.rhp “Import_SVG” 7.7.21151.13002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/BlockEdit.rhp “BlockEdit” 7.7.21151.13002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_AMF.rhp “Export_AMF” 7.7.21151.13002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoRenderCycles.rhp “Rhino Render” 7.7.21151.13002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/import_DST.rhp “Import_DST” 7.7.21151.13002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_PLY.rhp “PLY - Polygon File Format Export” 7.7.21151.13002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Import_AMF.rhp “Import_AMF” 7.7.21151.13002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 7.7.21151.13002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 7.7.21151.13002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 7.7.21151.13002

@chiaranottola

How long until the crash happens? 5 seconds or 5 minutes?

When the crash happens, did a crash dialog pop up? If so, did you send it in? You can also paste the crash dialog output text here. It will be very helpful.

-David

I just timed it, it’s 8 seconds. Here’s the crash report:
Rhino Crash Report.pdf (285.4 KB)

@chiaranottola,

Have you connected you Macbook Pro to an external monitor? If you close Rhino, disconnect the screen, start Rhino and try to render using your Macbook screen - does it work?

@chiaranottola

I am unable to reproduce this here.

  1. Could you try to run the RenderOpenLastRendering command and see if that works? It won’t render but it should show the render window. I would like to know if that works.

  2. Does it also crash when you try to render a model with only a box?

-Lars

Note that the user is using an M1 device here…

FYI, I have an M1 and have tried to reproduce this but I can’t.

I tried with RenderOpenLastRendering but I get this message:

"There are no recent renderings in the temporary folder

/var/folders/l5/zgy1cl913gv56r7lx22x70z40000gn/T/McNeel/Rhinoceros/V7/Rendering$Cache$"

I tried rendering only a box and it still crashes… only faster… 4 seconds

Thank you, I’ll go buy the cable to connect it in a couple hours, is there anything else I can try in the meantime?

@chiaranottola No no! There is no need to do that. In case you were already using a monitor I would have wanted you to test without.

If you don’t have your Macbook connected to a monitor you don’t need to do anything.

I will create a bug tracking item for the issue you’re having.

Here is the YouTrack item: https://mcneel.myjetbrains.com/youtrack/issue/RH-64568.

Okay, thank you. Do I have to do something with the bug tracking item?

Hello - no, nothing further for you do, as far as I know - hopefully, the developers will find the problem and fix it.

-Pascal

Hey @chiaranottola,

One thing that might help is deleting the Rhinoceros preferences. Try following these steps:

  1. Quit Rhino
  2. Open Finder
  3. Click Go > Go to Folder… in the menu bar
  4. Type/paste ~/Library/Preferences/com.mcneel.rhinoceros.7.plist and click ‘Go’
  5. Copy the com.mcneel.rhinoceros.7.plist file somewhere as a backup
  6. Delete the file.
  7. Restart Rhino

Additionally, could you please attach the above file here? I would like to take a look at why it might be causing the problem (assuming doing the above fixes the issue).

Hope this helps!
Curtis.

Thank you, I actually managed to solve the problem by uninstalling the software, backing up my computer, resetting everything and re-installing Rhino. I had already tried uninstalling and reinstalling before I asked for support but I guess I got lucky this time! It seems it’s working now, slower than before the crashing issue, but at least it’s working (I noticed it rendered much faster before the update confirming the compatibility with M1).