Problems with Windows 10 and 64 bit Rhino

I’m getting an error message when opening Rhino. Does anyone have a fix for the error message as follows:

This action cannot be completed because the other program is busy. Choose “Switch To” to activate the busy program and correct the problem.


Hi Catherine - can you please try a re-boot and see if that sorts anything out?


Hi Pascal,

I have rebooted it several times.


Hi Catherine - do you run plain Rhino, or are there some non-default Rhino plug-ins starting as well?


Hi Pascal,

I run Rhinogold 5.7.2 as well.


Ah. Well, does Rhino by itself start? If not, start in Safe Mode and disable Rhino Gold in Options > PlugIns page, and then close and see if starting normally works.
To start Rhino in Safe Mode, type “Rhinoceros” in the Windows Start menu - you should see entries for Rhino in Safe Mode - choose the appropriate version to start - usually 64 bit


Try this: in rhino options, turn off auto update. Restart.

The problem is usually caused by mcneel update service.

Ps: when it fails it also clashes with windows update service