Problems trying to customize my workspace


I’m trying to customize my Rhino / Mac UI. I have deleted buttons I don’t need from my “Standard” toolbar by right clicking in the empty space on the Standard toolbar and choosing “Customize toolbar.” When I go to “Rhinoceros -> Commands -> Customize” (I first made a copy of the default Tool Palette Set) I can see “Standard” under “Modified pallets”, but the button collection (to the right) doesn’t reflect the changes I’ve made. It still has all the buttons I deleted. I also - by mistake - added wrong button from the lower left panel to this modified Standard toolbar. How can I delete this button?
How can I add a command macro for a right click to a button? I’ve tried to follow the ‘instructions’ in Rhinoceros -> Commands -> Customize, but no luck so far…

In “Rhino preferences -> Mouse” I have the MMB to run this macro: !_ShowToolPalette _ToolPalette=Popup _UnderCursor=YES _Enter
How do I remove buttons from this Popup? I can add buttons, but not remove…


regarding the top tool bar: that one is standard osx stuff… to remove an icon from there, hold the command key then drag the icon out of the tool bar (similar to removing items from the dock)… you can also use the cmmd key to rearrange/reposition the icons.

if you’re in the top toolbar’s customize mode, you drag them out without needing to hold the cmmd key

Philip, I think that the “standard” palette is just an alternative to the top toolbar, but not the same one. I have reduced the number of icons in my toolbar and the “standard” palette still shows up as original, i.e. not modified. In your case the addition of a button must have shifted it to the “modified” category.
Removing a button: click and highlight, then click the “-” button at the bottom of the icons panel.
Adding a right-click macro: click and highlight a button, then add your macro in the right-most panel.
For all changes, make sure your command-editor is showing the Copy of Default set in the selection box at the top (and that you select that set as the active one).


Thanks Jeff for the cmd-key tip! I didn’t know that. However - it doesn’t seem to work on the Pop-up toolbar…


Thanks Max! The “-” sign! Of course :blush: I do know about the “+” and “-” signs - I just didn’t see them. I was too concentrated on dragging buttons around…
I tried to add a right click macro to a button. It works - in the editor - but the right click option doesn’t show up in the “real” toolbar in my workspace. No right click function and no tool tip either. I tried to restart Rhino also - didn’t help. Hmmm…


The “real” toolbar…, I take it you are talking about the toolbar at the top of the viewports window. I don’t think you can do anything to those icons, just add or delete them the way you described yourself by right-clicking in the empty space to the right of the icons.
The button editor works only on the palettes. Are you not confusing the toolbar and the standard palette as I said before? I would not know how to invoke the “standard” palette though…


Edit: I do now, you can assign it to the MMB, mouse preferences, second radio button.

As I understood it, all buttons are stand-alone, the fact that they show the same image in the toolbar and in a palette does not mean they have exactly the same functions. The same is true for lookalike buttons in different palettes. So they are not just pointers to the same set of commands and/or macro’s (I am going a bit out of my depth here, somebody prove me wrong please…)


Yes, with the “real” toolbar I mean the actual one - in the workspace - and not the one in the editor (the “standard” toolbar at the top). The icon I’d like to ‘change’ is in one of the drop down palettes (CPlanes): I’d like to add a macro (_OrientCameraToSrf _Pause _Flip=No _Pause _Cplane _View) as a right click option to the “Set CPlane to surface”-button. I did so in the editor, but it doesn’t show up in the workspace. I think it should. Probably something I’m missing…


The LMB should always have the same command for the same icon/button even if it exists in different places in the workspace - and also the right click option if it’s added in the command editor as this seems to be a “global” editor.
At least that’s the way I see it… No?


Philip, I will try to make my point a bit clearer with some pictures. First, I changed the MMB function:

Then I use the MMB to open the “standard” palette:

Now this palette contains the buttons that you edited, and not the lookalike one in the toolbar.

So right or wrong, the same icon does not always point to the same command. I have to add that I am talking from past experience, I did not test it this time around.


Philip, I reread your posts, and I may have misunderstood you after all. Did you say you edited the"CPlanes" palette and the changes did not show up when you invoked it from the toolbar?

Not quite… but that’s what I should have done probably. Have to try that when I get home to my Mac.


So how exactly does one add something to the top tool bar. I can’t drag stuff up there when in customize.

i posted that in sept2013… rhino for mac was different then… it’s now a single window application and you can no longer customize the top toolbar… you can make your own custom toolbar via:

Rhinoceros > Commands > Customize > Tool Palettes

for reference/clarity, this is rhino’s toolbar now:

if you’re talking about a different toolbar, please clarify.

Nope, just the top one.

Still figuring out how the whole palette customization thing works