Problem with shell command to make a shell from mass

Hi all
I used a boolean interaction for few objects both planar and non-planar and try to hollow the result with the shell command, but none of the results was close, I’ve also changed the tolerance of file and another method like offset surface and the use nonmanifold merge but it still does not work.
wants to know if there is any method at all for doing this in rhino, something that works well most of the time?!

i also upload the file if you wants to check the model

Uploadmodel.3dm (334.1 KB)

Umm I think the primary reason “shell” wasn’t working on this was just that it wasn’t closed. If you select the object the Properties panel tells you that it’s open. Close it up and it should work. Okay I tried that and it didn’t do it fully successfully, but that may have something to do with the tolerances, I don’t know what it was made at, but for shells to work the tolerances need to be TIGHT. 0.1 for the degrees and for the distances…well I wouldn’t model this in Meters, mm at 0.01 tolerance should be fine.

Nonmanifoldmerge is strictly for people who want to export ‘thin’ models for FEA.

oh sorry for that, before saving the file I did some unsuccessful tries and that’s why it’s an open object :smile: anyway here is the close one
Uploadmodel.3dm (351.4 KB)
as you said I changed the model scale to mm with a tolerance of 0.01 but it still doesn’t work.
also about the process of modeling all the objects made by a loft in grasshopper and then I used boolean intersection them with a simple box! is there any issue with the way it model?!!

Shelling in Rhino is unfortunately just not sophisticated enough yet to handle this type of object. One of the main problems are the numerous twisted surface extensions needed to create the inside shell and the difficulty of finding their intersections to trim.

One thing that can actually work better - but not perfectly - is to use OffsetSrf instead of Shell. First, extract the surfaces to remove as you would in Shell, and delete them. Then, call OffsetSrf and set the Corner=Round instead of the default Corner=Sharp; also set Solid=Yes. Instead of extending surfaces straight to meet each other, it makes radius blends between them. Playing with the tolerance setting (making it looser) can also help.

Unless you absolutely need the sharp corners, this usually works much better - but still often leaves a few open spots. These can usually be patched, with more or less work depending on the configuration. For example, I removed the lower surface from your object (after fixing the object so that it was closed and converting the file to meters as @JimCarruthers suggests), then I ran OffsetSrf with 0.5 meters to the inside, Corner=Round and Solid=Yes. This gave a result with a couple of naked edges in one area, which I was able to fix by just removing one surface and replacing it with a Patch. (it’s outlined with a red curve.). Makes a closed, solid polysurface suitable for 3D printing (but obviously not at 1:1 :stuck_out_tongue_winking_eye: ) FWIW.

Closed-Meters.3dm (1.3 MB)

1 Like