"Shell Result is Not Solid" ...even after trying so many things


(Dj263) #1

Star Light Two - shell attempt.3dm (609.7 KB)

Let me know if fewer polygons would be better or something; I have a few other file versions.

This is supposed to be a sort of ‘lampshade,’ for a lighting exercise project, but I can’t even get it to shell. I’ve had the thickness as high as .5in and as low as .0001in. I’ve played with the tolerances under Tools>Options>Units. I’ve tried inspecting the polysurface or mesh as best I know how. I just can’t get it to shell properly. Any idea why this is???


#2

I’m able to get some results with offset surfaces.

Star Light Two - shell Closed.3dm (2.0 MB)


(Pascal Golay) #3

Hello- This configuration is unlikely to work, you’ll have to do some hand surgery, but, please don’t make models with an absolute tolerance of 1.0 - there is a lot that will not work under those conditions.

https://wiki.mcneel.com/rhino/faqtolerances

-Pascal


#4

Yes, as Pascal says - your tolerances are huge for that size object. I reduced them to 0.01, exploded the model rebuilt the edges and rejoined. That left me with 3 sets of naked edges that were around 0.065 apart, I forced them closed with JoinEdge - not a good practice, but just to get the object out the door.

Then as Cyver suggests, OffsetSrf often works better than Shell for complicated objects, especially if you use the rounded edges option. I removed the “bottom” surface and hid it, then I offset the whole thing to the inside 0.5 inches. Then I showed the bottom and surface and trimmed it with the offset, and joined all back together. It’s a bit of a hack…

–Mitch

Star Light Two - shelled05.3dm (3.7 MB)


(Dj263) #5

Thank you so much to everyone here – Actually, given my original file, and everyone’s suggestions about OffsetSrf and tolerances, I was able to get it to easily close exactly how I wanted. I just had no idea what I was doing in the tolerances before. THANK YOU!!!