Problem with mesh point inclusion

Hi guys. So I’ve been using Karamba for a while now, and I’ve just encountered an issue that never had happened to me before, where the IPts plug in the brep mesh component is just not working (it does something but not what it should) and I just can’t find out why, it doesn’t seem to be a resolution issue, just some shenanigans with the way I extract the points I plan to include (which doesn’t look that weird to me).
It really is a very basic file I was trying to make which makes it all the more strange, and also I’ve worked with similar files, done by someone else in the past, and as long as the surface and box intersected each other Karamba didn’t have any trouble interpreting those intersections (regardless of resolution), so maybe this isn’t the best way but I know there should be one that worked.
I upload both the file and a picture to see if someone could help me find the issue.
Thanks in advance
Prueba lámina.gh (21.6 KB)
Prueba lámina.3dm (77.6 KB)

Hi, try to pull the pull to the original surface and it seems to work. This is sometimes due to the tolerance in Grasshopper/Rhino.

image

It worked perfectly! thanks! I usually work in grasshopper only so that’s why I didn’t know of the tolerance issues, but in this case the morphology had to come from Rhino, hence the question. Always good to learn something