Problem with high-res images continues


#1

Have a look at the differences between 2 imgs.
Same scene, different resolution.
it goes wrong with both: arctic and rendered views.



Upper: scren res
Bottom: high res


#2

So this problem applies also to the wireframe (some faces are in ghosted mode):


High res washes out all colours.


(David Eränen) #3

Hi @Piotr,

I created a scene with two boxes, one of the red and another blue. I switched to rendered mode and did a ViewCaptureToFile at a resolution of 4200x2720. The colors look as they should on the output.

Could you give me more information on how to reproduce this? If possible, please send me the model.

-David


#4

Hi David

it happens on a two different files I have worked recently.
Check this one as it is smaller.
survey vs patch.3dm.zip (5.3 MB)
Good luck.
P
PS I don’t know how to reproduce it except saving large image :slight_smile:


(David Eränen) #5

@Piotr,

I am still not able to reproduce the bug using your file. Are you using ViewCaptureToFile? If so, what settings are you using in the dialog?

Here’s mine:

And here’s the result:


#6

David
It’s weird indeed. I am using View Capture but without screen dialog (command bar only).
Is there anything I could check / do for you?
P


(David Eränen) #7

Please paste the text in Help -> System Information...

-David


#8

There you go. Bootcamp and stuff.


Rhino 6 SR4 2018-4-10 (Rhino 6, 6.4.18100.1591, Git hash:master @ b6485d60ae29d5ee76751120dc9232f8b172e934)
Licence type: Commercial, build 2018-04-10
License details: Cloud Zoo. In use by: Piotr ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-BNUR9UE

Radeon Pro 555 (OpenGL ver:4.5.13474 Compatibility Profile Context 22.19.128.1)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.5
Shading Language: 4.50
Driver Date: 4-3-2017
Driver Version: 22.19.128.1
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\Calc.rhp “Calc”
C:\Program Files\Rhino 6\Plug-ins\NamedPositions.rhp “Named Position”


P


(David Eränen) #9

We just tried to reproduce it on a Macbook pro with a Radeon Pro 555 running Windows on Bootcamp. It works fine here.

Have you made any changes to line thicknesses? Your line colors look thicker and more pronounced on your normal-resolution captures compared to my captures.


#10

Yes, i have used modified Wireframe with extra line thickness, but this problem exist whether there are lines, surfaces or hatches. it wipes colour from all instances.


(David Eränen) #11

@stevebaer Do you know what might be going on here?


#12

Also, flat shading (for meshes) doesn’t work in some modes, at least here. I am talking about meshes imported from Max via obj format with messed normals (unify mesh normals doesn’t help).


(Steve Baer) #13

Just to make absolutely sure, can you try ViewCapture with the dialog and the settings that David is testing? I want to make sure we are performing the exact same tests.
Thanks


#14

Steve
That made the trick. I had my shortcuts imported from RH5 and, apparently, the shortcut for ViewCapture was invoking the test command (with dash).
It works as it should, test images attached:


Upper one: screen resolution
Lower one: high resolution
Thanks for help
P


(Steve Baer) #15

That’s good news. What were you exactly calling in the dashed version that was causing the bug? I would like to still figure out how to repeat this so I can create a bug report.


#16

-ViewCaptureToFile
or something like that. Exact command but with the dash-ed prefix