Problem surfaces, F6 camera, dot


#1

I have 3 problems here.

  1. Rhino default assigned to the F6 key camera. I always use the F5 key to Exposé. Sometimes to use Exposé I happen to accidentally press the F6 key, then activate the camera all open files and you can not turn it off.
  2. using the dot, the cursone of the text is not highlighted and it is not clear how to position it. Also trying to paste text in the window of the dot, Rhino will hang for about 20 seconds and the text will be pasted not.
  3. I can not divide the green surface using the ciano surface.
    using the intersection command can be seen that the surfaces do not intersect.
    The green surface was obtained by using a sweep 2 of surface edges.
    The cyan surface was obtained by an offset surface of a surface created from a blend surface.
    _Edit:_ extracting the edges of the green surface and using the sweep 2, it creates a surface that can be cut. However it would be useful to know why the initial surface can not be cut, in order to avoid this problem in the future.
    Thanks in advance
    srf green no split.3dm (3.8 MB)

Software information

Software versions
Rhinoceros version: 5.4 WIP (5E63w)
Rhinoceros path: /Applications/RhinoWIP.app
IronPython version: 5.1.2015.131
WIP expiration: 12 maggio 2017
Language: it
macOS version: Versione 10.12.4 (Build 16E195)

Plug-ins
/Library/Frameworks/3DconnexionClient.framework/Versions/A/3DconnexionClient

Third party kernel extensions
com.logitech.manager.kernel.driver (6.40.1) C1D41FB7-7A01-38E3-A769-65B1DE65B0FD
com.3dconnexion.driver (10.4.3) CDD8E81B-F6DA-3673-B781-9AB464363E29
com.kairos.driver.DuetDisplay (2) ACE0314B-69A7-3100-9155-3B4B6C96B2EC

Hardware information

Computer hardware
Hardware model: iMac13,2
Processor: Intel Core i5-3470 CPU @ 3.20GHz
Memory: 32 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GTX 680MX 2048 MB
Memory: 2048 MB
Screen size: 2560 x 1440
Displays: iMac (109dpi 1x)

USB devices
Apple Inc.: Bluetooth USB Host Controller
Apple Inc.: FaceTime HD Camera (Built-in)
Inateck USB to SATA3 Bridge: Inateck Generic USB Device
Lexar: WorkflowD512
GenesysLogic: USB3.0 Hub
3Dconnexion: SpaceMouse Pro

Bluetooth devices
Sconosciuto:
Apple: Apple Wireless Keyboard
Apple: Apple Wireless Trackpad

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-10.16.34 355.10.05.35f05
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bit
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: Yes

Appearance settings
Antialiasing: 2x
Mip map filtering: Nessuno
Anisotropic filtering: Nessuno


(Pascal Golay) #2

Hi Simon - thanks, I’ll see if I can reproduce these.

@Zsimon - F6 should toggle the camera… so far it does do that here - if you accidentally F6, hit it again to turn the camera off… that is what is not working for you?
The Split works in V6, not in V5… so I think it’s safe to say that it’s Rhino’s fault… it does work to first IntersectTwoSets the cyan and green and then split the green with the curves that reslt.
I am not able to reproduce the cursor problem, so far - I see the cursor when creating or editing a dot.

-Pascal


#3

Hi Pascal
I have a video

  1. The intersection creates a non-continuous curve. Despite this you can use! Split?!
  2. 1 '19 ", the cursor works correctly in the dot box.
  3. 1 '36 "if I copy a text (in this case by the translator) and try to paste it into the dot window, often NOT work ( DO NOT operate the combination Cmd + V (paste) instead works right click> paste) but obviously NOT the cursor. Moreover NOT work 3Dconnexion mouse (but it works your regular mouse). If I go to another modeling window 2 '27 "the 3Dconnexion working properly. 2 '33 "the 3Dconnexion has resumed work.
  4. for the F6 key, I solved it by deleting from that command settings. First … The room was activated by F6 and for some reason (perhaps an interference with F5 Exposé, you could not turn it off. When you open a new blank file, was shown the room and I could NOT turn it off.

#4

@pascal Same problem here with Trim, Split, Intersect.
It’s been a while and I do not remember how the two surfaces were generated.
Considering that the edges have many segments, it hypothesizes that the 2 surfaces may have been generated by extrusions which were then used for boolean operations. The 2 surfaces have been extracted from a polisuperfice and then used the command _UntrimAll
The question is … why the two initial surfaces No Trim, no split, Intersect partial?
No Trim, no split, Intersect partial .3dm (2.6 MB)


(Pascal Golay) #5

Hi Simon - the reason the problem occurs is that the original green surface has a knot line right at the intersection - it looks to me like it once ended there and then was extended with ExtendSrf > Type=Line (extends tangent and linear) That would leave a kink (fully multiple knot) at that location. When extending surfaces, use Type=Smooth (extends curvature continuous) as a rule, to avoid this potential problem. The underlying problem is Rhino’s, it should know how to intersect along a fully multiple knot.
(V6 gets it right, btw)
-Pascal


#6

Hi Pascal -I understand the problem. I removed the nodes at the intersection but still could not help trim. Being a flat surface, I removed the other nodes (see picture) and now it works. To extend the surface, normally use the settings that you suggested. Now I understood the problem, I will pay attention to the nodes.
Thank you
Simon